thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-2850-A Has green light and fan but No chime, No video

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-2850-A Has green light and fan but No chime, No video

    I am new here but have a 820-2850-A that has green light and fan spin but that is it. No chime, No video. Where should I start? There is no liquid damage.

    also wanted to note that a usb mouse does not light up when plugged in
    Last edited by corona2640; 05-14-2017, 07:18 PM.

  • #2
    CPU Vcore present on L7415?

    Comment


    • #3
      I get 1.11v

      Comment


      • #4
        Remove RAM and see if machine beeps. Case speaker needs to be connected. Any history on this board? This kind of failure usually doesn't "just" happen.

        Comment


        • #5
          Yes it does beep when ram is removed. I do hear the HD spin up not sure if that matters. When i plug usb mouse in it lights for a fraction of a second during the plugin process and then goes off

          Sorry no history on this computer. I got this in a bulk lot

          Comment


          • #6
            Are you using known good PC8500 RAM? Try 1 slot at a time. Inspect board for damage and corrosion.

            Comment

            thread bottom ad

            Collapse
            Working...
            X