thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-3437 LD, after UC and jumpers OK(?) but no green light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3437 LD, after UC and jumpers OK(?) but no green light

    Hi guys,

    This one came in from another service shop dead. They already UCed with generic chinese bath.

    I did once more with Crest to clear their flux (which was all over the place) and also ensure a better bath and after that I jumped a corroded line and a missing resistor BOTH next to the SMC.

    Now when I connect the magsafe the fan starts, I get ALL_SYS_PWRGD but no green light..

    PPBUS_G3H at F7140 is 8.3 to 8.4V
    PP3V42_G3H at 3.45V
    SMC_BC_ACOK is also HIGH

    other voltages present too..

    Any ideas?

    br,
    george







  • #2
    Could be corrosion on J9500, bad magsafe board or a bad flat cable.....

    Comment


    • #3
      ok I just had the guy bring me the LCD, there is also no backlight - are these related? or should I also find a new flat cable (tried DC board and magsafe is sound, original 85W)

      BKL_EN, EDP_BKLT_EN, BKLT_PLT_RST_L are missing.

      There is 8.5V output at the backlight fuse which means its not boosting but the FB trace is ok and I also replaced the driver L8550 (before I checked the Enable since there was corrosion there too).

      Comment


      • #4
        Why are you measuring at the fuse? All that tells you is if the fuse is good or not, not that its not boosting. It sounds to me like the board may not be posting? Whats your LCD Enable voltage? Have you tried an external display?

        Did you jump the resistor? was it meant to be 0Ohm?

        Anyhow the way to tell if its not boosting is to check past the feedback, one of those big caps near the LVDS should show you your true backlight output voltage.

        Comment


        • #5
          check SMC_LID....

          Comment


          • #6
            Originally posted by ALB-Repairs View Post
            Why are you measuring at the fuse? All that tells you is if the fuse is good or not, not that its not boosting. It sounds to me like the board may not be posting? Whats your LCD Enable voltage? Have you tried an external display?

            Did you jump the resistor? was it meant to be 0Ohm?

            Anyhow the way to tell if its not boosting is to check past the feedback, one of those big caps near the LVDS should show you your true backlight output voltage.
            sorry you are right at the fuse I measured the expected voltage, at D7701 where I checked for continuity for the FB there is no output.

            also the SMC_LID is HIGH.
            the CPU although it gets 1V does not warm up.. it does but only a little...

            Comment


            • #7
              So, no external video????

              Comment


              • #8
                Is there even an image?

                Comment


                • #9
                  unfortunately no image from display port to HDMI adapter. CPU runs veeeerrrryyyy cool.. the wine was spilled in the middle of the laptop back so around the CPU area.. maybe the CPU is gone?

                  Comment


                  • #10
                    u1950 id guess.

                    Comment


                    • #11
                      why you think that ALB? it is the "PCH PWROK Generation", IC ID: 74LVC2G08GT

                      Comment


                      • #12
                        CPU Vcore present on L7310?

                        Comment

                        thread bottom ad

                        Collapse
                        Working...
                        X