thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-00045 keyboard and trackpad not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Come on man, missing half the pins.......

    Comment


    • #17
      Originally posted by dukefawks View Post
      Come on man, missing half the pins.......
      I don't understand. I gave the measurements for even pins from 2-40 and I thought the odd numbers from 1-41 where the previous measurements I gave from the connector that is on the trackpad.
      Where are the other half of the pins so I can measure them and do I need to keep the trackpad flex cable plugged in?

      Comment


      • #18
        So 1 and 3 have 8V, did you even compare this to the schematic and how this is impossible.

        Comment


        • #19
          I assumed pins 1 and 3 were on the connector that was on the trackpad but from reading the schematic it says its on the bottom side of the logic board which means I would need to disconnect the battery and measure under the board.
          Last edited by ytesfay80; 07-18-2017, 05:06 AM.

          Comment


          • #20
            Okay could you just help me to get it back working as it was before so I can send it back to the customer working as it was before.
            Now when I plug in the charger the machine doesn't turn on. Before the customer would keep it in sleep mode and I have a usb keyboard that would wake it up from sleep but its not turning on anymore.
            I disconnected the keyboard and trackpad cables and plugged in the charger to see if the screen would turn on but it doesn't.
            I get 3.3v on PP3V3_S0SW_LCD of j8300.
            I also still got 8.2v on F4800 as well as 3.3v on SMC_ONOFF_L on J4801.

            I tried shorting Pin 22(SMC_ONOFF_L) of J4801 to ground but that didn't work either.
            Last edited by ytesfay80; 07-18-2017, 05:13 AM.

            Comment


            • #21
              I haven't done anything to this machine except for try different flex cables. The last time I touched it was about 2days ago and it was turning on. The only thing I've messed with since then was the trackpad cable/connector while leaving the battery connected.

              Also, I measured the trackpad connector with no cables plugged in and I didnt get any voltages except for on SMC_LID, SMC_ONOFF_L and PPBUS_G3H_TPAD_FLT.

              Shouldn't the machine turn on as soon as the charger is plugged in?
              Last edited by ytesfay80; 07-19-2017, 02:11 AM.

              Comment


              • #22
                I went to the power aliases page and took measurements on the G3Hot, 5v, and 3v3 rails with the charger plugged in.

                All of the "G3Hot" (Always-Present) Rails were present and measured fine except for PPVBUS_E85 which measured 14.9v instead of the 20v the schematic says.
                There was 5v on PP5V_G3H_LDO but no voltage on all the other 5v rails and nothing on any 3v3 rails.
                PP5V1_S4SW was also 0v as well.

                Comment


                • #23
                  I have no idea man, you could have poked/shorted anything at this point. You fucked it up.....
                  15V on E85 is the normal voltage and would indicate SMC and everything is running.

                  Comment


                  • #24
                    Okay could you help me with which component creates the 5v_s4 rails and the 3v3_s5 rails. I'm looking at the schematic but I can't seem to find where they are created.

                    I checked all the main power rails and none of them are shorted to ground in diode mode with battery disconnected.
                    I checked L7520 where PP5V_S4 should be and it never has any voltage on it even when I initially plug the charger in.

                    larossmann If I sent this to you how much would you charge to fix this if I send you the trackpad and cable also?
                    Last edited by ytesfay80; 07-20-2017, 02:58 AM.

                    Comment

                    thread bottom ad

                    Collapse
                    Working...
                    X