thread top ad

Collapse

Announcement

Collapse
No announcement yet.

SPI resistors getting dragged down

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SPI resistors getting dragged down

    Board is 820-3476

    R6101 and R6103 resistors connected to PP3V3_SUS are getting dragged down somehow. I cannot figure out why. When they er mounted to the board they measure R6101: 0,8K instead of 3,3K and R6103: 1K instead of 100K. When I pull them readings are correct according to schematics. When I put them back (or mount new ones which measure fine until they are mounted) they read too low again.

    Diode mode reads 0,370 on PP3V3_SUS. A little too low voltage drop but cannot find the culprit.

    I injected 3V into PP3V3_SUS and C1204 getting hot. I removed it and nothing else gets hot. But still resistors near U6100 reads incorrectly.

    Any idea to what is going on and what's my next step?

    Thanks

  • #2
    There is stuff in parallel with the resistors so they will never measure correct in circuit, they are fine. What does the board do right now?

    Comment


    • #3
      It's not starting. It was trying to start at one point where it chimed but then rebooted. New chime. Reboot. This happened faster and faster so that the chime became half chime. Something like:

      Chime.....
      Chime..
      Chim
      Ch
      Ch

      I stopped it and took out spi and read the data from it. Data looked corrupted. I flash new EFI on brand new chip and put it back on the board and now it is not even starting. Then I tried with a SPI from another working board. Still not starting.

      I measure around and see missing SYS_PWR_OK_R. Like this gate don't open because of missing signal from SMC.

      But I suspected the SPI resistors because when I measure them in a working board the read correctly. And also the corrupted data in SPI rom lead me this way.

      And why do they measure correctly in circuit in the working board when you say they never will?

      Thanks
      Last edited by Sykulski; 06-29-2016, 03:31 AM.

      Comment


      • #4
        Prbably some charge left in caps/FETs, leave the board for a while and measure again.
        But what was the original issue with this, seems like water damage to me.
        I hope you saved the original ROM!

        Comment


        • #5
          Original issue was small water damage. R8112 was corroded and U8010 burned. Else every other part of the board was fine. I did not have PP3V3_S3 at that point but after ultrasonic cleaning and replacement of these two components power came up and it did the "chime-thing" described earlier.

          I still have original ROM (still have the chip) but it is corrupted as some info is missing , ie. no serial number, and contents look different when comparing to a ROM from working board.

          Comment


          • #6
            Is it turning on now and CPU Vcore present?

            Comment


            • #7
              No it's not turning on. It only started this one time doing the chime boot loop but after I turned it off it did not starts again.

              CPU Vcore is present.

              Comment


              • #8
                Must be corrosion somewhere else still. Usually on these it is U1950 area or SMC area.

                Comment


                • #9
                  Probably SMC. Board wants to have it's own life. Sometimes starting to spin the fan when I measure around in different places. No consistency. And when I get fan spin the fan slowly goes high RPM (like it should because i have it out from casing with nothing connected). Then I can take magsafe out and in a couple of times sometimes fan spins sometimes not. After it spinswhen applying magsafe for 2 or 3 times I connect a screen to see whats going on but then it decides to stop spinning and back to initial problem where i am missing SYS_PWROK_R and SMC_DELAYED_PWRGD at U1950.

                  U1950 area looks fine. Anyway I switched U1950 on your recommendation but still the same. I tried to heat SMC to 150 C with some flux under but still the same.

                  Comment


                  • #10
                    Sykulski did you fix it?
                    I have the same problem...the laptop was working fine i left the office after 5 minutes I come back the screen was black I try to turn it on and I get the chime and then 75% of the chime and then 50% and so on. What was the problem?

                    Comment


                    • #11
                      No I didn't fix it yet. I put it in the to-do pile and wanted to get back to this with fresh eyes some day. But it is still lying there :-)

                      I suspect mine has several issues because of the inconsistency in power and the weird chime-thing. The SPI was for sure corrupted because when I read the contents of the chip they were corrupted. But the power thing related to sometimes starting sometimes not I don't have a clue. I don't know which of these issues results in the chime-thing though.

                      I will update if I ever get back to this one. I'm sorry for the lack of help here :-(

                      Comment

                      thread bottom ad

                      Collapse
                      Working...
                      X