thread top ad

Collapse

Announcement

Collapse
No announcement yet.

[SOLVED]820-2915 No charging doesn't boot from charger, However starts with battery inserted

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]820-2915 No charging doesn't boot from charger, However starts with battery inserted

    [SOLVED] Solution: Use 85W Power supply instead of 60W

    Hi,

    I have a 820-2915 motherboard which had a broken backlight issue, however after fixing the backlight it seems its not the only issue it had. (I repaired the backlight by replacing the fuse). The board looks relatively clean but it has a few signs that may show someone else worked on it before. I think the issues might have been caused by the very cheap adapter the previous owner used as I don't see anything indicating water damage or spots that used to be water damaged. I notice a few spots with solder that may looks like it has been reflowed though (Not replaced).

    The system works perfectly when running on battery power and if you connect the magsafe charger it will run off the charger, however it won't charge. If you plug the charger in without battery connected the system won't boot. However if you connect a battery the fans start spinning and they system will boot (But run of the charger). You can remove the battery from the motherboard once its running and it will work just fine.
    The Charger always shows a green light

    --

    I already tested if power was being generated with only the charger in.

    These are the rails:
    - PPBUS_G3H: OK
    - PPVIN_S5_HS_COMPUTING_ISNS: OK
    - PPVIN_S5_HS_GPU_ISNS: OK
    - PPVIN_S5_HS_OTHER_ISNS: OK
    - PPDCIN_G3H: OK
    - PP3V42_G3H: OK
    - PPVRTC_G3H: OK
    - PP5V_S5: OK
    (PP5V_S3 is not there, however thats probably because its not in a S3 state)
    (PP5V_S0 is not there, however thats probably because its not in a S0 state)
    - PP3V3_S4: OK
    - PP3V3_S5: OK
    (PP3V3_S3 is not there)
    (PP3V3_S0 is not there, but it shows up with ~0.07V on it, can probably be ignored)

    I know it can take power from the charger and I know the rails are being created, however why doesn't it charge or want to boot up running Charger only? Is this possibility a BGA issue (Like the SMC not properly registering a charger) or am I just missing something?

    Thanks in advance
    Last edited by smiba; 09-22-2016, 03:06 PM.

  • #2
    Is the charger an ORIGINAL 85W?

    Comment


    • #3
      I thought it was an 85W charger but it seems I've been using a 60W the whole time! I'm not sure where my 85W magsafe charger went then, A new one should be in my mail in a few days.

      I'll test it again with a 85W charger and report back, sorry for the inconvenience

      Comment


      • #4
        The only charger on your desk should be an 85W, no need for anything else.

        Comment


        • #5
          The 60W charger was indeed the issue, tested it with a 85W charger and it booted up without any issues.

          I recently rearranged my whole desk but for some reason I managed to swap my 85W charger with a 60W charger I had laying around, stupid mistake.
          My bad for wasting your time and thanks a lot for the reply, I wouldn't have suspected the charger at all since I just finished a repair with it before this one, but that obviously was a less demanding 13" macbook.

          EDIT: The motherboard stopped working after a little while and often wouldn't want to boot again. I replaced the DC inboard with a known working part and it now works without any issues.
          Last edited by smiba; 09-22-2016, 07:43 PM.

          Comment

          thread bottom ad

          Collapse
          Working...
          X