thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-2850 not turning on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Well, go check the usual for green light. 3V42? SMC_RESET? ACOK?

    Comment


    • #32
      I get 0v on all of those. The only voltage I get is on PPDCIN_G3H. It pulses every few seconds and only goes up to 0.25v

      When I measure in diode mode on pin 1 of R7010 I just get OL.

      Comment


      • #33
        Something wrong in 6259 circuit. Do you have a fake chinese charger to check, it will not shut down like an Apple one.

        Comment


        • #34
          I only have a fake 60w charger.

          Comment


          • #35
            60W is fine for testing this.

            Comment


            • #36
              Ok. The fake charger lights up. SMC_RESET_L and pp3v42_g3h are both high. SMC_BC_ACOK is 3.26v and ppbus_g3h is around 0.09v (F7040 is still removed from the board)
              Pins 27/28 of U7000 - 20.7ohms - Pins 17/18 - 3.1ohms
              Last edited by ytesfay80; 10-08-2016, 10:53 PM.

              Comment


              • #37
                Short on PPBUS?

                Comment


                • #38
                  No short on ppbus_g3h. In diode mode I get 0.49 on Pin 1 of F7040(PPBUS_G3H).
                  Could this be an issue with the isl6259? Should I try putting a new ISL on there?
                  Last edited by ytesfay80; 10-08-2016, 11:27 PM.

                  Comment


                  • #39
                    Test all sense resistors and traces first then replace 6259

                    Comment


                    • #40
                      I think I might just send this machine back.
                      I replaced the ISL6259 and the green light came on I was able to see PPBUS_G3H was pulsing from 12.56 to 4v on Pin 1 of F7040. I also took some other measurements.
                      U7000
                      Pin 13(CHGR_RST_L) - 3.36v
                      Pin 3(CHGR_ACIN) - 4v
                      Pin 2(CHGR_DCIN) - Pulses from 16.2v to 15.7v

                      Then minutes later the green light went away as if the isl died again. I replaced with another 6259 and that had a dim green light until about 20 minutes later I plugged the charger in and the light turned green again. The light went away and I replaced the 6259 again and now it is again giving me a dim green light and 0v on SMC_BC_ACOK.
                      I don't know what keeps killing the ISL6259. All of the sense resistors and the traces are fine.
                      Last edited by ytesfay80; 10-09-2016, 02:25 PM.

                      Comment


                      • #41
                        I dunno, this may not be worth the effort. Could be SMC issue too.

                        Comment


                        • #42
                          Okay. This is going back.

                          Comment

                          thread bottom ad

                          Collapse
                          Working...
                          X