thread top ad



No announcement yet.

Thoughts on this 3662/3787 "fix"?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Thoughts on this 3662/3787 "fix"?

    Was looking around Google today, wondering if any progress had been made with the 3662/3787 CPU issue, and came across this:

    Any idea what this app/utility is doing? Surely it can't be a fix, as some of the CPU issues I've seen on these boards prevents power. But, is this a separate issue? I've seen this video dropout/reboot issue as well, but also some units that hang and won't booting up at all. I sort of just attributed every CPU-issue as being one overarching issue (shit CPU or damaged traces inside board). Are the issues related, or totally separate issues? Would a software fix be possible for the particular units that will boot, but have the video dropout and restarting issues?

  • #2
    That will just keep the CPU running under some load so it doesn't lower Vcore. Eventually the issue will get worse and crashing will happen all the time. This solution is just a temporary patch like reflowing a GPU.


    • #3
      Oh ok, thanks duke. Wasn't sure if maybe it would give insight into the exact issue with the CPUs on those boards. Thanks!

      Do you have an opinion on whether or not this issue will eventually affect all/most 3662/3787 boards eventually (i.e. after being pushed hard over and over), or if some might not have the issue inside the board, etc?


      • #4
        I have no idea at the moment and am not even sure what is the exact problem besides something with Vcore. I have no time to waste on figuring out this issue. I see maybe 1 every month so I have other things to spend my time on at the moment.


        • #5
          Hey Duke, sure thing, I understand. We have a stack of them here if you're ever wanting to dive into it. I'd be happy to send you a few, just shoot me a message. Thanks again!


          • #6
            I have sent one to Apple for repair last week. I will inspect their replacement board to see if they did anything in the Vcore area. Somehow my gut feeling says there is an issue with the CPU itself though


            • #7
              I have noticed something odd with several of the affected boards:

              1. When internal video drops (before board ever restarts/cuts off), I can usually restore it by plugging in a thunderbolt display. External video comes up and internal video begins working again as well. I don't recall any of them restarting as long as this was maintained.
              2. They all lose internal video again if you unplug the tbt cable.
              3. Some restart a few seconds later after unplugging the cable; some don't and will continue to work if you plug in the tbt cable/display again.

              Unsure if it's related to the issue, but did think it was interesting. If you learn anything from the Apple-repaired board, I'd be glad to contribute to whatever cost you incurred to send it to them.


              • #8
                An old topic, but i see that i am referenced, so i will chime in. This issue is extremely likely an internal defect to the CPU itself. You can watch the CPU voltage drop shortly before the crash and then of course a few seconds later the whole machine shuts down. My speculation is that an update to the firmware in 2016/2017 tried to get some better battery life by enabling a very low voltage cpu state (watch it in Intel Power Gadget, drops way low before crash). This was not part of the initial design so a significant portion of units are not stable at that voltage level. The utility will keep the CPU from ever entering that state. For what it's worth this is in use on a few thousand machines all of which successful to my knowledge. I have my doubts that Apple will ever officially acknowledge and push out a fix for this, as it would be an admission of the defect, as well as harm battery life on those machines that are not crashing.


                • #9
                  i also got one board that was crashing and spent many hours try to figure what was wrong with it, nothing worked, then as a last resort i retinned all qfn chips and it has been 2 months and its still working fine.


                  thread bottom ad