Recent content by nininunz

  1. nininunz

    820-01700 no power, cycles between 5v and 19v

    Ignore me I'm dumb. Had my desktop psu current set low so it was maxing out and restarting the system. It actually works fine.
  2. nininunz

    820-01700 no power, cycles between 5v and 19v

    Just tried testing with a known good battery. Turns on and fires right up but refuses to charge. Still stuck in that 5v-19v cycle. Not sure where to go from here ¯\_(ツ)_/¯
  3. nininunz

    820-01700 no power, cycles between 5v and 19v

    Ok so messed with it for a bit and here to report back. Yes all ports behave the same. I inspected the board and noticed a loose cap on the mesa circuit (C4955) and reflowed it. There was a bit of dust on the board so I dunked it in the ultrasonic. Plugged the bare board into my BY-3200 cable...
  4. nininunz

    820-01700 no power, cycles between 5v and 19v

    Haven't had the chance to inspect yet. About to pull it out now. Only the second A2141 board I've worked on so not familiar with common problems. Figured I'd ask if this is indicative of anything specific. But it just jumps from 5v to 19v for a few seconds then the meter goes blank like it was...
  5. nininunz

    820-01700 no backlight + other issues

    Yeah I changed them, they're all good now. Went to test and omfg this shit making me want to punch a hole in the wall. How tf does this happen? The fucking speaker amp is foaming. WHAT THE FUCK. I'm going to go cry now :(
  6. nininunz

    820-01700 no backlight + other issues

    Ok I'm pretty dumb. Checked all the backlight caps again and one WAS bad :/ One was also bad before when I was fixing the initial water damage though. Is there something else wrong that is potentially killing these caps? Or is it just bad luck?
  7. nininunz

    820-01700 no backlight + other issues

    Side note: wtf is XW8410? It's on the board view but not the PDF and does not even have pads on the physical board.
  8. nininunz

    820-01700 no backlight + other issues

    LCD connector has no damage, looks perfect. PPVOUT_S0_LCDBKLT is 12 ohm to ground
  9. nininunz

    820-01700 no backlight + other issues

    Ok well that didn't last long :/ While testing the machine the display just died on me. Power cycle brings me back to my original issue, image but no backlight. Pulled the board back out and both rows of backlight caps are short to ground. I'm still terrible at understanding schematics lol. A...
  10. nininunz

    820-01700 no backlight + other issues

    Weird update. Noticed LB7000 and L3500 look kinda funky. Shown is LB7000, L3500 is not as bad. Any idea what would cause this? Good to just replace or is something else the root cause and gonna make it happen again? They're both USBC related. Neither is near where I saw the magic smoke before...
  11. nininunz

    820-01700 no backlight + other issues

    Ok so I hook it all up and it fucking worked. All this time it was just that diode =/ Aaaaaaaaaaaaaaaahhhhhhhh I'm literally crying lmfao
  12. nininunz

    820-01700 no backlight + other issues

    I wouldn't get voltage on the display backlight pins without being connected?
  13. nininunz

    820-01700 no backlight + other issues

    nope not burnt. but damn I totally molested this board :/ I think I may have actually put D8410 on backwards. Can you confirm? Also note L8450 and C8463 are off the board. Neither should be crucial for display backlight though. I think. Since I'm not putting a load on C8463 just probing display...
  14. nininunz

    820-01700 no backlight + other issues

    Ok so this board has been thru hell :/ Had water damage. Fixed water damage and it worked perfectly. Was putting back in top case and there was a bee in my room and I kinda maybe might have thrown the board at the bee :p and surprisingly everything still worked perfectly except the backlight. I...
  15. nininunz

    820-00850 no audio

    My bad. And I meant like check what? Voltage? Resistance? Well anyway this board seems to have made its way from no audio to the no power board pile. Sits at 20v 0.03A with only the charger connected. Fun.
Top