thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

[SOLVED]820-2915-a no power, no green light

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • andrew boren
    replied
    awesome well next time ill have an idea how to test that little package. thank you, can i get you to close this thread please and thank you for all your help

    Leave a comment:


  • dukefawks
    replied
    Not really, you can remover the gate resistors and then test if both FETs open and close. Check on youtube how to test a FET. The gate needs to be disconnected from everything to do that.

    Leave a comment:


  • andrew boren
    replied
    7080 was the problem, i had a feeling it was, is there now way to test that part?

    Leave a comment:


  • dukefawks
    replied
    That means U7000 should be ok. Change Q7080 and check the gate voltages and resistors to U7000.

    Leave a comment:


  • andrew boren
    replied
    ok got the fake charger, ppbus_h3h is 12.56. what else should i check?
    R7005/21/22 all have power, r7005 is 18.5, r7021 is 19.03 and r7022 is 19.03
    Last edited by andrew boren; 12-06-2016, 01:52 PM.

    Leave a comment:


  • dukefawks
    replied
    When you put 18.5V in the system the 3V42 bus should at least come high.

    Leave a comment:


  • andrew boren
    replied
    ok so even putting in 18.5v in on pin 2 of f6905 and plugging in the 85w apple charger, did not give a green light. i do have a fake charger on its way, praying its fake, spending less than 20$ on it and it has no apple logo. lol, is their any more testing i can do before the new charger arrives?

    Leave a comment:


  • larossmann
    replied
    Remove F6905. Place 18.5v from a real bench power supply on pin 2 of F6905. Then plug known good 85w charger in with known good dc in board. If it works, Q7080 is bad.

    If you do as duke says and get a knockoff charger this will be easier to troubleshoot.

    Leave a comment:


  • dukefawks
    replied
    Last time, get a fake charger for trouble shooting. Then we can go further with this.

    Leave a comment:


  • andrew boren
    replied
    the mac works with a third party charger, at least it did, if i had a short wouldnt it never have worked? it i remove the fuses 7040 and 7041 i shouldnt get any power since PPBUS_G3H would be disconnected to the system.

    Leave a comment:


  • dukefawks
    replied
    Short on PPDCIN, 3V42? Also remove F7040/41 without U7000 you risk getting the full adapter voltage on PPBUS!!

    Leave a comment:


  • andrew boren
    replied
    with or without u7000 i get no 3v42 power , green light for one second then it goes off, and wont come back on unless i leave it unpluged for a few min

    Leave a comment:


  • dukefawks
    replied
    ACOK is not being pulled low by U7000. Is 3V42 present now?

    Leave a comment:


  • andrew boren
    replied
    if u7000 is removed what makes the green light still come on? my problem lies there

    Leave a comment:


  • dukefawks
    replied
    Uhm, take the board with the bad GPU to Apple for a free repair.....
    Get a fake charger for trouble shooting.

    Leave a comment:

thread bottom ad

Collapse
Working...
X