thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-3115-B Green Light No Power

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3115-B Green Light No Power

    Hello,

    I have an issue with an 820-3115-B board. Board was liquid damaged - put it through the ultrasonic cleaner and powered it up - green light and fan spinning. Great! Disconnected magsafe and went to have something to eat. Came back 10 minutes later will not power on: gets green light but will not power on at all. I have the following readings:

    PPBUS_G3H: 12.62V
    PP3V42_G3H: 3.497
    PPVRTC_G3H: 3.337
    PP5V_S5: 5.01V
    PP3V3_S5: 3.3V
    PP5V_S3: 0V
    PP3V3_S3: 0V
    PM_SLP_S4_L: 0V


    Got a weird issue where I get a short to ground on PP5V_S3 when the machine is plugged in but the short goes away after you leave the magsafe unplugged for a while?

    Any help would be appreciated with where to check next. Thanks

  • #2
    Where was wather damage?? Check RTC resistors (R1800 to R1803) should have around 3.3V on both sides.....

    Comment


    • #3
      Water Damage on top of board around EFI chip, SMC and thunderbolt chip and similar area on the other side of the board.

      RTC resistor values:

      R1800: 3.332V pin 1 3.236V pin 2
      R1801: 3.332V pin 1 3.057 pin 2
      R1802: 3.332V pin 1 3.327 pin 2
      R1803: 3.332V pin 1 3.327 pin 2

      R1800: 325K
      R1801: 1M
      R1802: 20K
      R1803: 20K


      Checked some other voltages:

      PP5V_SUS: 0V
      PM_SLP_SUS_L: 0V
      PP3V3_SUS: 0V

      Signal for these comes ultimately from U1800 so guessing a dead MCP?

      Reverse diode reading on PP1V05_S0: 0.006 so guessing I have a short there also?

      Time to give up on this rabbit hole to hell?

      Comment


      • #4
        No MCP on this board, i guess you mean PCH....... Check for any missing or corroded component around SMC and bios chip, replace all bad parts, also you can try apply flux and heat SMC to remove the crap under the chip.....

        Comment


        • #5
          Sorry PCH! I'm new this this when it comes to the advanced hit your head against a wall stuff. Tried reflowing the SMC with flux to get rid of any crap under the chip but didn't change anything nothing really corroded around the area. As far as I can diagnose it will not go into an S3 state because it's not getting the correct enable signals which seem to come from U1800.

          Guessing this is most likely an SMC or PCH issue? Yay!

          Comment


          • #6
            PP5V_S3_REG comes high for a second or nothing at all??? If you have a slow multimiter, may not be readed, so use osciloscope if you have....

            Could be bios problem, double check SPI lines and resistors, do continuity test............
            Last edited by aprendiz; 05-10-2016, 04:54 PM.

            Comment


            • #7
              Nothing at all on PP5V_S3_REG. Replaced BIOS - no change. Have given up on this one for now thanks for the help anyway.

              Comment


              • #8
                Replaced RTC Chip U2600 and I get an S0 state and the fan is spinning! No video output or chime though - will keep investigating but at least that's one problem solved! Thanks

                Comment


                • #9
                  Put back original bios.....

                  Comment


                  • #10
                    Have done I think I have a U7400 problem as a few burnt probe points around those. Will check further and get back to you

                    Comment


                    • #11
                      OK new issue: machine turns on but I get no video output. I have no voltage on PVCORE_S0_CPU and PVCORE_S0_AXG. All other main voltage rails appear to be present.

                      I get a reverse diode reading on both of these CPU rails of 0.002V with U7400 removed.

                      Is this a normal diode reading or does it seem like I have a short to ground on the CPU side?

                      If so how do I go around figuring out what's causing it - if I inject voltage here from a bench power supply the CPU gets hot but this would make sense as the CPU is turning on. It's hard to work out if anything else is getting hot and shorting though?

                      Apologies if I'm missing/doing something stupid I've never had any U7400 or CPU Voltage problems before.
                      Last edited by jb23; 05-11-2016, 05:28 PM.

                      Comment


                      • #12
                        Quick update. I replaced U7400, R7402, R7403, Q7510, Q7520 and Q7550 and I now get 1.118V on PPVCORE_S0_CPU but get 0V on PPVCORE_S0_AXG.

                        Any ideas of what to check next? I read in another forum that BIOS can cause this so I replaced the BIOS chip again but still no luck. Thanks so much!! Hopefully I'm near the end of fixing this absolute nightmare board
                        Last edited by jb23; 05-12-2016, 09:00 AM.

                        Comment


                        • #13
                          Display is plugged in??? this voltage comes up when display is detected...

                          Comment


                          • #14
                            Yes - plugged everything back in and I get a solid sleep light on the front, DVD drive does it's auto eject thing like it's about to POST and then nothing. No video ouput on display and 0.001V on PPVCORE_S0_AXG

                            Comment


                            • #15
                              When the DVD drive does it's auto eject thing PPVCORE_S0_CPU goes down from 1.118V to 0.919V

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X