thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-00840 S5 rails not steady

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-00840 S5 rails not steady

    Struggling with this board that was very clean.
    The S5 rails are jumping up and down from 50% to 100%.

    PPBUS_G3H 13v steady
    Charger 20v 0.01A
    PP5V_S5 jumping 2.5v-5v
    PP3V3_S5 jumping 1.5v-3.3v
    PP3V3_G3H 3.4v

    P3V3S5_EN pulsing 0 - 3.3v
    PP3v3_S5 diode mode around 18K.
    PMIC_EN_P3V3S5 pulsing
    U7650 replaced - still pulsing
    U1900 replaced - still pulsing

    It doesn't appear to charge the battery either, but the cell voltage was really low.


  • #2
    Looks like a problem in a secondary power supply.
    First of all, try to start in SMC bypass, to discard a SMC sensor issue.
    Next, check if any PM_SLP_Sx_L signals pulse at least.
    Check for short on all big coils.
    Any pulse at L7670?
    What about 3V3_SUS?

    Comment


    • #3
      Does CPU VCore pulse as well?

      Comment


      • #4
        Thanks for the response guys.
        Tried SMC bypass, no difference.

        PM_SLP_S5_L shows 20mv every now and then, but otherwise 0v.
        Nothing on PM_SLP_S4_L - 0v.

        It doesn't get anywhere through the power up sequence, so there's no Vcore.

        There's no pulses on L7670 as there's no P5VS4_EN signal.

        3v3_SUS comes from PP3V3_S5G right? I'm not getting this cos its dependent on PP3V3_S5 via U8205
        Last edited by SargFowler; 07-07-2019, 12:19 PM.

        Comment


        • #5
          "Tried SMC reset, no difference."
          I said SMC BYPASS; many times explained on the forum...

          Comment


          • #6
            Sorry, typo. It was a bypass, not a reset.

            The battery should still charge even without S5 state shouldn't it?

            Also, just discovered PP1V_S5 has a short. It's 1R. That's gotta be too low surely?
            Last edited by SargFowler; 07-07-2019, 01:38 PM.

            Comment


            • #7
              If VCore doesn't pulse check all rails for shorts seems you may have found one

              Comment


              • #8
                I've injected voltage into the PP1V_S5G rail but couldn't find anything getting remotely hot. It took 1v at 1a.
                I've also noticed PP1V8_S5G is also low resistance. I hope this doesn't mean the CPU is blown.
                I removed FET Q8060 but the short is still there on the PP1V_S5G rail

                Can anyone else provide readings for these rails on a good board please?

                Other observations are:
                PP5V_S5_LDO jumping 2.5v - 5v
                CHGR_ACOK 3.4v
                SMC_PM_G2_EN steady 3.4v

                Diode mode tests:
                PP3V3_S4 0.439v
                PP5V_S4 0.40v
                PP5V_S5 0.40v

                I'm trying to figure out if it's a short or a signal problem.
                Any advice greatly appreciated.
                Last edited by SargFowler; 07-09-2019, 02:41 PM.

                Comment


                • #9
                  "It took 1v at 1a"
                  That means 1W only.
                  Probably nor even FLIR cam will detect something; but could be an option to try.
                  You can also inject until 1.3V without risk.

                  Lift pin1/L8060 ans see where the short remains.
                  If on pin2, then is probably bad CPU...
                  Last edited by 2informaticos; 07-10-2019, 05:55 AM.

                  Comment


                  • #10
                    I've temporarily removed Q8060 which is just before L8060 and the short was still there.

                    I'm going to check the PP5V_S4 circuit to see if there's an issue on this rail as the other side PP3V3_S5, appears OK even though the voltage is briefly there.

                    However, I thought the board would stick in S5 state if it couldn't get into S4 and wouldn't reboot as this board seems to be doing?

                    Comment


                    • #11
                      "I've temporarily removed Q8060"
                      U7800 is still connected there.
                      That's the reason I told you to lift L8060.

                      If S5 voltages pulse, board could try to move into S4, or something connected to S5 rails is bad.
                      Did you try the board alone, without anything connected?
                      Only charger, eventually USB mouse.

                      Remove R7661/62 and see if get steady voltage at L7670/90.

                      Comment


                      • #12
                        OK, with L8060 removed, 43K on pin1, 1R on pin2. PP3v3_S5 still jumping.

                        I just have the board on the bench, nothing else connected.

                        R7662 removed, no 3v3 S5.
                        R7661 removed, PP5V_S4 still jumping up to 5v (?!)

                        I'm going to try injecting in to each S5 rail to make sure they're OK.

                        Comment

                        thread bottom ad

                        Collapse
                        Working...
                        X