thread top ad

Collapse

Announcement

Collapse
No announcement yet.

[SOLVED]820-3462 doesn't see battery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]820-3462 doesn't see battery

    I'm stuck here. I don't know what to measure.
    Got a 820-3462 board with not a sceric of water damage to be found under the microscope.
    Laptop works fine on cord but battery is always showing an X.
    Tried a new battery and a working second hand battery. Same prob.
    Power rails exist obviously because it turns on. So SMC? How do I tell if this problem is the SMC or not?
    Pretty confused on this one.
    Thanks.

  • #2
    Most likely cause is "THE screw" is missing.

    Second most likely cause is something pulling down SMBUS communication on the line between the SMC, the battery, and the ISL6259.. which can be either the SMC, the battery, or the ISL6259.

    If there is no water damage, it is most likely "THE screw" is missing. It's one of the screws holding the battery to the board, and if not present nothing with the battery will work, it is not magnetic, so everyone loses it.

    Comment


    • rob777
      rob777 commented
      Editing a comment
      Bloody excellent! Screw was missing. Took one out another and fixed!
      A fkn screw tho..... Ffs.
      You sir are a bloody legend!

thread bottom ad

Collapse
Working...
X