820-01598 - A2159 Unable to load Mac OS

Hi Team,

I've got a 820-01598 which is showing a folder logo. Checked all SSD voltages and reset lines, all good.

Understand we can't just boot from a USB installer on these T2 models.

I've tried Catlina internet recovery installation, while plugged via ethernet, it allows me to select the drive then gets me to accept terms and after crashes. Then loads back into the folder logo.

This may be something super simple.

Thank you in advance for your advice.
It has no OS & administrator account, I believe it's been previously restored.

It gives us the message: Recovery is trying to change system settings: No administrator was found.

Is there anything else we can try?
No Data to Save.

Have tried a DFU restore, but it doesn't load the OS onto the Mac.

Is it supposed to automatically reinstall the OS after being restored?

After successful restore, the host mac shows a lock symbol. The restored mac shows nothing but when rebooted goes back to folder flashing.
Sorry for the delay in reply.

Yes, we can start internet recovery. But the system crashes when it starts installation.

We've double checked nand voltages, 0.9, 1.8 & 2.5. all present.

We thought we found a short on 2.5Nand but it was an error in diagnosing.

Could this be nand failure without a short?
Last edited: