820-2330 charging problem, mosfet always got killed


New member
Im having a 820-2330 logic board,a1286.

the problem of the machine is that, it can't charge the battery. it shows "X" sometimes and "0%" sometimes.

wanted to check those two SMC to u7000 signal and see if they are 3.3v

but always before those, for this board,once you connect the charger and battery together, it will kill the mosfet q7055.
I already replaced it twice, same result,once connected, 3 seconds later, you can smell something and it's killed and shorted from D to S.

and yes, tried couple known good battery already.

any advice?
thank you


New member
I replaced u7000 as well and q7060 , Now it doesn't burn the mosfet any more, but can't power on with battery only.

the system can recognize the battery and see the percentage,but can't charge, it shows battery 50%, but can't run on battery once i unplug the charger.
check the current sensing resistors already.


Q7055/7056 is probably bad. A dead battery is also an option. The battery being recognized does not prove it is OK.