820-2828 Imac 27" 2011 - GPU issue

Gurmon

Member
Hi All,

Quite a few names on here i already recognise from AR & CM forums.

Anyway, I have a slightly different issue with this iMac 27" 2011. It came in with the usual GPU issue. This is no problem, as we ordered a NEW GPU card from Apple.
This all went fine, card replaced imac working fine, no issues at all, passed VST, AST ASD etc etc.

Next day just before calling customer, we tried it again. NO IMAGE/BACKLIGHT this time.
On further inspection, LED 3 is not illuminated. I assume we have been shipped a duff card from Apple. Not the first time, but quite rare.
We try 2 more new cards, and none of these work. All these cards are fine, so it must be a logic board issue.

Other than the logic board supplying PP5V_S0, PP3V3_S0 & PP12V_S0, what else should i be looking out for ?

Thanks
 

dukefawks

Administrator
Do you still have the original bad video card? Remove the heat sink and heat up the GPU to about 100C. Touch it with a wet finger and it should sizzle. If the GPU was bad the card will now work again.
If this is a 6970M card, Apple is sending out junk!
 

Gurmon

Member
no, old card went back to Apple sometime ago. Im going to try heating the new card. It is a 6970M.

Will report back in a few hours.
 

dr. moast

New member
Do you still have the original bad video card? Remove the heat sink and heat up the GPU to about 100C. Touch it with a wet finger and it should sizzle. If the GPU was bad the card will now work again.
If this is a 6970M card, Apple is sending out junk!
Hi,

I just stumbled over this as we have quite a few iMacs here with bad GPU. Can you explain this a bit further? What is the reason behind this?

THANKS!
 

dukefawks

Administrator
You need to replace the GPU nothing else to say about this. Heating them up is just to confirm the GPU was bad.
 

Nico

New member
Hello,

Just reopening this thread as I'm looking where to source the GPU to replace a defective one. Duke, would you mind giving us any link for this ?

Thank you very much
 

dukefawks

Administrator
0811000 is not available. Need to edit VBIOS and replace with 215-0798000/8002/8006. Even those chips are hard to find REAL new ones. No idea who has real new ones at the moment. Send some messages to the big sellers on Ebay like SEE and E-Best. All the shit on Aliexpress that was listed as new were reballed that I got.

Do you have experience in BGA rework, these are huge chips and are quite a challenge to solder correctly. Also you need to flash the ROM.
 

Nico

New member
Thanks a lot for your answer Duke. When I had a very bad time to find the other ones... I actually found 216-0811000 in Europe at a decent price...

I must confess that my experience on BGA rework is not amazing but I managed to get my hands on a ZM-R6200 at a very cheap price. I assume it will help a lot. But any advice would be greatly appreciated...
I remember that in a video on Louis youtube channel, it was said that the original heating programs were not the best and they needed some change. Do you know anything about this ? (I'm thinking now that I should create a new post for this as it could be quite useful to many people)
 

dukefawks

Administrator
There are no new 811000 chips! All cards that you find will be baked. Do not waste money on this.
Also if this will be you first BGA repair you picked the worst chip to try this on.
 
Top