A1990 2018 820-01041, fans on, no post, no display

amp meter shows it's drawing 20.3V and 3+amps, and an iPhone plugged in is getting about 5V and 1 amp. It went into dfu mode for configurator but no luck tried monterey Big Sur and Catalina, tried external monitor, tried safe mode and all the usual T2 commands for smc pram etc, tried target disk mode, tried with and without battery connected, tried disconnecting everything including trackpad, no caps lock light and obviously no chime. The fans always start up when you do anything to power it on, sometimes the fans stay on quiet, and sometimes the machine turns off after a minute with a high fan spinout. when I long press the power button to turn it off, and then unplug the usb c power adapter, the fans will turn back on again after a few seconds, and sometimes stay on and sometimes "spin out". PPBUS_G3H is 12+V. suggestions? thanks in advance!
Last edited:
all of these remain at the levels listed for at least a minute. my original post comments about configurator were my DFU mode attempts. is there a different CPU temperature I should be looking at? There are many CPU core points on this board but not sure which if any should have certain voltage. thank you


Staff member
PPVCC_S0_CPU is the CPU core.
It should drop to 0.6-0.7V when the board boots.

Test the board alone on the desk; disconnect keyboard too.
Measuring CPU core is sufficient to see if board boots.

"cpu_pwrgd, cpu_vidsclk, cpu_vidalert, and cpu_vidsout all measure just barely above 1V"
Good enough; all of them are pulled-up to 1.05V.
ok, hopefully I'm doing this right. I do not know of a way to have the battery plugged in, so I have the multimeter probes where they need to be and then I plug the board into power (96W genuine apple) and monitor voltage. at that point, the voltage reads zero for about 10 seconds and then .975 forever, I never see it at .6/.7. what should I infer from this, is the board stuck, not booting?


Staff member
Something went wrong with T2, or its SSD partition.
Apple sells garbage since 2016.
DFU is supposed to fix problems; doesn't help too much in reality.