[SOLVED]820-00165 No magsafe, missing 5v & 3.3v


Hi, I have another 00165 board that has had liquid damage. Cleaned and had magsafe light for a while but wouldn't spin the fan.

I left it for a few days while I repaired others, but when I came back to it, its back to no magsafe again.

PPBUS_G3H = 8.2v
PP3v42_G3H = 3.4v
PP5V_S5 = 0v
PP3v3_S5 = 0v

L5001 (PP3V3_S5_SMC_VDDA) = 3.4v both sides
R5198 & R8140 (SMC_PM_G2_EN) (S5_PWR_EN) 0v
U7501 Pin 23 (VIN) 8.2v

I'm not sure where to go from here. Any help would be appreciated


New member
PPBus_G3h is too low which indicates a faulty or non enabled SMC (which is why, no light on magsafe)
Corrosion near SMC? SMC reflowed?


I’ll check tomorrow. Removed the SMC to check for crap under it, but it looked fine. I’ll put it back on tomorrow and check SMC_RESET_L

There was a bit of corrosion near the SMC, one test point was fkd so had to jump it but nothing major. (This was all prior to posting) Not reflowed the SMC up until now, just ultrasonic.


Well it looks like I was a little lucky with this one. After removing and reballing the SMC, it now shows the magsafe and even fired up! All rails are there and seems to be fine. On to the next. Please mark this as solved as I'm assuming I can't do it.