Sony Vaio SVF152 Series SVF1521MCXB wont turn on completely dead no light nothing

djpat1974

Member
Hi, I have a Sony Vaio SVF152 Series SVF1521MCXB Intel i7-3217U Motherboard DA0HK9MB6D0 that wont turn on or show any led lights i checked the basic parts like battery and ac wall charger once plug in the laptop remain dead no sign of power please see my attachment.
 

Attachments

Last edited:

aprendiz

Moderator
Do you have schematic??? Have you measured any voltage??? Do you have VIN on pin 6 from PU7?? give more info please.....
 

djpat1974

Member
i even reset the bios still dead i get short from 5 capacitor that are in the photo please let me know if you can view the picture i can do it over again
 

djpat1974

Member
need help with this Sony Vaio SVF152 Series SVF1521MCXB wont turn on completely dead no light nothing one member charm in any more ideas will help thanks
 

aprendiz

Moderator
ok, you sent me a PM where you say "no voltage on pin 6 from PU7" now I read here "PU7 VIN pin6 19 volts", so, what is it yes or no???? maybe it is jus in protection mode, remove bios battery and main battery without charger and push power button for 30 secs, after this put back bios battery and charger and push power button again, see if it turn on......
 

djpat1974

Member
hi that is my fault i wasn't getting power to pu7 by my error that is why i corrected it maybe i should of explain my self i tried the protection mode removal but no good this normally work for me in many Sony mother board repair but this one is different
 
hi,

there are few things to check first
1. Do you have 3.3 volts on power button , (please press and check if the voltage drops)
if you have then 3v 5v regulator is most likely working . if you do not have then you need to check the 3v 5v regulator .


2. In case you have the 3.3 volts on power button and the voltage drops when you press it then you need to check Sio for rms rst and plt rst voltages on Sio .

if sio is good then rsm rst should come out when you press power button .


please check this and update , if you have voltage on power button try RE PROGRAM BIOS IC ) . thanks
 

djpat1974

Member
hi i replace the NPCE985L and now the TPS51427A gets very hot i change it and still it gets very hot please help me with this thanks
 
Top