Today I learned



Had a late 2013 retina macbook w/ weird symptoms. Will boot maybe 1/10th of the time, graphical artifacting on boot screens, or failure to boot at all. Crazy fan spin.
Found out serial # missing after attempting to boot in to ASD. No signs of any liquid damage at all.

Looks like bad ME region, I have seen this happen when customer powers off the laptop in the middle of a firmware update.

I pulled firmware from chip, replaced ME region with appropriate clean one per instructions, flash back to chip. Still doesn't work. Chip is 8 MB Micron flash 25Q064A and I don't have another...
So I decide to pull a Macronix MX25L606E from a macbook air and flash that with the same... it worked!

I couldn't find information online, but it appears that you can swap the firmware chip if it is similar enough (same size memory, same package).



Edit: Very strange I just looked up datasheets foe the chips and the micron 25q064a part that was on the board states voltage is 1.7-2 volts max... but the power input to bios chip is 3.3v...
The macronix part is rated at 3 volts.
Any thoughts?
Last edited: