thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-3462 water damage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3462 water damage

    i have a mac that tries to turn on, that just sits and spins the "right" fan, the "left fan never kicks on, with that being said. how do you test this board? since it wont power up without the battery plugged in, and you have to screw in the battery how do you test voltages on the side of the board facing down? also i don't seam to have a board view file just schematics, any advice on this one would really help

  • #2
    The board doesn't start without battery, why would you want to check voltages with battery connected???
    You must make it works with charger only...
    First be sure to use correct charger.
    Check SMC_BC_ACOK, SMC_ADAPTER_EN, PM_BATLOW_L, green light on magsafe...
    Last edited by 2informaticos; 02-18-2017, 06:52 AM.

    Comment


    • #3
      this board starts fine with no battery connected. It'll just run slow.

      is this doingg that thing where the fan spins for a quarter of a second then dies? If so, check clock area, check current sensing around ISL6259.

      Comment


      • #4
        I meant his board doesn't start without battery.
        But there is n reason to try repair it with battery, as he needs to repair it on charger only...

        He complained cannot measure because need to connect battery.
        In fact he don't need to connect battery.

        Comment


        • #5
          ok knew this one had the special battery bridge, thought it needed to have a battery to turn on. with the screw in, and power comming from charger it turns right on, with screw undone it does nothing but greenlight. once i get a chance ill test voltages, with that said i did ask about brd view files for this board. i do have schematics. but im not well versed to know what part matches up to the schematic

          Comment


          • #6
            omg nvm im just blind, i have the brd file...

            Comment


            • #7
              Remove the board from case.
              It should start by itself when you plug (original) 85w charger...
              Then you can measure what you want on the desk.
              Be aware PM_BATLOW_L low means normally fake charger. But still could be something else.

              Comment


              • #8
                PPBUS is probably not present.

                Comment


                • #9
                  sorry been waiting on a few parts, ppbus_g3h is 12.6 on r6905 , the one fan died, so that takes care of the no fan spinning up, i do have green light. but it just starts up and never chimes. smc is safe to assume is ok, right?

                  Comment


                  • #10
                    Fan spins? Do you get a light on the USB mouse?

                    Comment


                    • #11
                      and figured out why it wouldnt turn on without battery, bc someone switched my charger with the 45w i used the 60w and its powering like it should. just wont boot

                      Comment


                      • #12
                        what do you mean light on the usb mouse?

                        Comment

                        thread bottom ad

                        Collapse
                        Working...
                        X