thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

[SOLVED] 820-3435 Green light only when battery is disconnected

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] 820-3435 Green light only when battery is disconnected

    This is an Air 11" 820-3435

    Came in dead with no light in charger.

    - When I disconnect the battery green/orange light comes up and all is working fine. (SMC_BC_ACOK = 3.11V)
    - When I connect a charged battery no light in charger but runs fine from battery. Not charging off course (SMC_BC_ACOK = ~200mV)

  • #2
    Can you post some voltages from ISL6259?
    In both cases...

    Comment


    • #3
      Have you tried another battery??

      Comment


      • #4
        PPBUS_G3H is 16 volts instead of 8.5v because of shorted Q7130. The light turns off because if the machine sent 16v to your 8v battery it would explode. Believe it or not PPBUS_G3H can go from 8 to 16 with no system damage, all downstream power rails are designed to adapt and adjust their switching frequency accordingly.

        Check it!

        Comment


        • #5
          I missed some measurments here??

          Comment


          • #6
            2informatico: I will take some ISL measurements later

            larossmann: PPBUS_G3H is 8.60V on charger and 8.45V on battery (97% charged)

            aprendiz: Yes i tried with another battery

            I also tried to start the machine from charger with battery disconnected and then plug the battery while running (yeah I know... but I took the chance) and then it continues running, discovers and charges the battery just fine. If I now take out the charger and plug it again then no light and no charging.

            Comment


            • #7
              Replaced IO board and flex yet?

              Comment


              • #8
                Yes. Same symptoms with known good IO board and flex

                Comment


                • #9
                  What is the resistance between pins 17/18 & pins 27/28 of U7100?

                  Comment


                  • #10
                    17/18: 2.9 ohm
                    27/28: 20.12 ohm

                    Comment


                    • #11
                      R7180 was open. Replaced and solved. Thanks guys

                      Comment

                      thread bottom ad

                      Collapse
                      Working...
                      X