thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

[SOLVED]820-2879 Q7035 Keeps shorting to gnd

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]820-2879 Q7035 Keeps shorting to gnd

    820-2879 came in not powering on w/ No water damage. Found dead short on PPBUS_G3H... Ran power found Q7035 getting very hot... Replaced it short gone, Got a green light w/o fan spin... PPBUS_G3H voltage was 3v. ISL had a hole burned through it so I replaced it.... No green light... Checked my soldering and even tried a new chip. I decided to measure PPBUS_G3H again and it was dead shorted AGAIN. Ran power, found the same mosfet getting hot... Removed it and short gone.... Stumped... What could keep causing the mosfet to burn out. Thank's Duke or Louis in advance.

  • #2
    Replace U7000, Q7030 and Q7035 at the same time, aslo check R7005 and resistance between pin 17/18 and 27/28........

    Resistance between pins 27/28 should be about 3ohm
    Resistance between pins 17/18 should be about 20ohm

    Comment


    • #3
      Current sense is OK. Replaced U7000 twice

      Comment


      • #4
        Out of mosfets.... Ordered a bunch more... will arrive next week

        Comment


        • #5
          Had 2 mosfets come in for another 2879, So I replaced both Q7035 and Q7030 and shorted again... Clueless

          Comment


          • #6
            Originally posted by aprendiz View Post
            Replace U7000, Q7030 and Q7035 at the same time
            If you replace ISL and do not replace mosfets, the shorted mosfet will burn the isl, now you replace mosfets but ISL is bad and will burn mosfet, this will happen endlessly...........

            Comment


            • #7
              Thank you... That makes sense... Mosfets will be here next week ordered a bunch.

              Comment


              • #8
                Got the mosfets.... Replaced them and the ISL... No change... r7005 is good.. PPBUS_G3H still dead w/o green light.. No short to ground on PPBUSg3h or pp3v42. Replaced u6900 and u6901 as well with no change.... PP3V42 is present and chrgr L gate has continuity to mosfets from ISL..

                Comment


                • #9
                  It's the SMC. Sysonewire is missing... Replaced u6900 and u6901.. SMC BC ACOK is present but still nothing. This is a rabbit hole.

                  Comment


                  • #10
                    Still PPBUS should come on with 12.3V with a dead SMC.

                    Comment


                    • #11
                      dukefawks This is is really strange.... Replaced the fets... Replaced the ISL... R7005 is good.. Current sense is good... PPBUS is dead.. 3v42 is good... Don't know what else it could be... No shrt on PPBUS either... Maybe something to do with SMC_BC ACOK?

                      Comment


                      • #12
                        Sense resistor circuit. No green light either? ACOK high?

                        Comment


                        • #13
                          I think I am getting trolled by a bad from the Reel ISL.... ACOK was low I believe.. I'll take another shot at in a day or so... No voltage on Chargr L Phase... It had PPBUS G3H before I replaced the fets and the ISL but it was high at 16V... So i think I just put on a dud ISL... Will update. And yes current sense is OK. No Green light..

                          Comment


                          • #14
                            dukefawks OK... I have restored PPBUS. However, Still no green light.. I'm thinking bad SMC or u6900...

                            Adapter Sense = 1.09v
                            Sys One wire is jumping between .30 and .75 v
                            SMC BC ACOK _VCC is 0.13 v
                            SMC BC ACOK is 3.21 v
                            PPBUS_G3H is 12.23v So the SMC is on?
                            PP3v42 is 3.42v ....

                            So right now I am leaning towards a dead SMC or dead u6900...

                            Comment


                            • #15
                              Forgot to add... SMC_Reset_L is 3.41 v

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X