thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3435 keyboard trackpad only work in OS AND FAN RUNS IN FULL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3435 keyboard trackpad only work in OS AND FAN RUNS IN FULL

    Hello guys , please I need your help, have got a MacBook Air 11inch whose keyboard/trackpad will only work in OS and the keyboard fan runs in full speed.

    HISTORY : initially the machine would intermittently switch off , so I had to replace the SMC and it works except the issue above, so I thought maybe the SMC was not good so installed another one , but still the same.

  • #2
    Have you even tried a new trackpad/trackpad flex or at least inspected them for corrosion???

    Comment


    • MOMOH
      MOMOH commented
      Editing a comment
      yes, and still same thing , Sorry for my late response

  • #3
    Inspect USB_TPAD_P/N lines for corrosion.
    Post U4810 voltages before login to OSX; remove internal SSD to avoid system booting.
    If also fan runs always high, makes me thinking both problems could be generated by trackpad board/flex.
    Start trying known good ones.
    You can run corresponding ASD EFI version and see what error pops up.

    Comment


    • #4
      Thank you so much 2informaticos and John .. I will post the value you requested tomorrow , we are closed now .. I appreciate your help

      Comment


      • #5
        On U4810
        PIN 1 = 3.3V
        PIN 2 = 0V
        PIN 3 = 0V
        PIN 4 = 0V
        PIN 5 = 3.3V
        PIN 6 = 0V
        PIN 7 = 0V
        PIN 8 = 3.3V

        TPAD_SPI_IF_EN_CONN circles between 0v,1v,2v when the keyboard is not connected , but straight 0V after connecting the keyboard

        Comment


        • #6
          Also when I use an external keyboard trackpad it works in EFI

          Comment


          • #7
            Missing TPAD_USB_IF_EN signal at U4810; check diode mode to ground.

            I hope you measured with trackpad connected.

            Comment


            • #8
              Originally posted by 2informaticos View Post
              Missing TPAD_USB_IF_EN signal at U4810; check diode mode to ground.

              I hope you measured with trackpad connected.
              9Yes with trackpad connected, Diode mode to ground is OL

              Comment


              • #9
                Check R1619.
                If good, then is PCH issue.

                Please, do NOT quote an entire post visible few centimeters above.
                Maintain forum aesthetic...

                Comment


                • #10
                  Thank you so much , will also refrain from the above

                  Comment

                  thread bottom ad

                  Collapse
                  Working...
                  X