thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-3435 keyboard trackpad only work in OS AND FAN RUNS IN FULL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MOMOH
    replied
    2informaticos Thank you so much, the machine worked , R1619 was 2.5V thank you everyone

    Leave a comment:


  • MOMOH
    replied
    Thank you so much , will also refrain from the above

    Leave a comment:


  • 2informaticos
    replied
    Check R1619.
    If good, then is PCH issue.

    Please, do NOT quote an entire post visible few centimeters above.
    Maintain forum aesthetic...

    Leave a comment:


  • MOMOH
    replied
    Originally posted by 2informaticos View Post
    Missing TPAD_USB_IF_EN signal at U4810; check diode mode to ground.

    I hope you measured with trackpad connected.
    9Yes with trackpad connected, Diode mode to ground is OL

    Leave a comment:


  • 2informaticos
    replied
    Missing TPAD_USB_IF_EN signal at U4810; check diode mode to ground.

    I hope you measured with trackpad connected.

    Leave a comment:


  • MOMOH
    replied
    Also when I use an external keyboard trackpad it works in EFI

    Leave a comment:


  • MOMOH
    replied
    On U4810
    PIN 1 = 3.3V
    PIN 2 = 0V
    PIN 3 = 0V
    PIN 4 = 0V
    PIN 5 = 3.3V
    PIN 6 = 0V
    PIN 7 = 0V
    PIN 8 = 3.3V

    TPAD_SPI_IF_EN_CONN circles between 0v,1v,2v when the keyboard is not connected , but straight 0V after connecting the keyboard

    Leave a comment:


  • MOMOH
    replied
    Thank you so much 2informaticos and John .. I will post the value you requested tomorrow , we are closed now .. I appreciate your help

    Leave a comment:


  • MOMOH
    commented on 's reply
    yes, and still same thing , Sorry for my late response

  • 2informaticos
    replied
    Inspect USB_TPAD_P/N lines for corrosion.
    Post U4810 voltages before login to OSX; remove internal SSD to avoid system booting.
    If also fan runs always high, makes me thinking both problems could be generated by trackpad board/flex.
    Start trying known good ones.
    You can run corresponding ASD EFI version and see what error pops up.

    Leave a comment:


  • JohnB8812
    replied
    Have you even tried a new trackpad/trackpad flex or at least inspected them for corrosion???

    Leave a comment:


  • 820-3435 keyboard trackpad only work in OS AND FAN RUNS IN FULL

    Hello guys , please I need your help, have got a MacBook Air 11inch whose keyboard/trackpad will only work in OS and the keyboard fan runs in full speed.

    HISTORY : initially the machine would intermittently switch off , so I had to replace the SMC and it works except the issue above, so I thought maybe the SMC was not good so installed another one , but still the same.

thread bottom ad

Collapse
Working...
X