thread top ad

Collapse

Announcement

Collapse
No announcement yet.

Hakko FR-901 not heating properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hakko FR-901 not heating properly

    Hello,
    i have a question about my Hakko FR-801. I used it now for something like one or two years and it always works perfektly fine. Now i feel like it is not really heating as much as it is used to. I would normally exchange the heating element and don´t mind that. But the real problem i have with it is, that it shuts off while i´m working with it. The blinking red LED stops blinking and i can not turn it back on. After a few minutes it automatically starts working again. Is that also related to the heation element? Is it to hot and needs to cool down a bit or what is going on with it? Thanks for any help.

  • #2
    Is it even an original one or a China clone?

    Comment


    • #3
      I think / hope its original. Its not from ebay, amazon or so. I searched and found this site: ( https://www.hakko.com/world_network.html ) where they list this company: ( http://www.kullik.com/startseite/hakko ) as the only Hakko distributor for Germany. I got it from there.

      Comment


      • #4
        I really don't know what could be wrong with it. The element would be the most common and the maybe a break in the cable.

        Comment


        • #5
          This is 100% related to heating element, mine used to do the same thing when heating element died. Get a new one.

          Comment


          • #6
            Thank you both for the help and the great support here in general. I already ordered a new one.

            Comment

            thread bottom ad

            Collapse
            Working...
            X