00165 - LIO's USB not working

Alan.L

Member
USB port next to Card reader is working fine, but the USB on the LIO I/O is not working.
  • i've already tried another flex cable and LIO I/O board.
  • USB mouse, USB flash drive doesn't work.
  • J9500 is very clean under the microscope
when i plug a usb device, osx will say "device is using too much power"

pin1 of usb port has 5.1v.
usb_pwn_en is 3.3v



diode mode on J9500 :

pin 3 - 0.474
pin 36 - 0.434
pin 38 - 0.434
pin 42 - 0367
pin 44 - 0.365

these measurements are same as a known working board. so I don't know what else to check...


bad cpu??
 
Last edited:

Alan.L

Member
forgot to mention, isight doesn't work. I've already tried aknown working display.

J4002 , pin12 has 5v,
PP1V8_CAM has 1.8v
PP1V35_CAM has 1.3v
pp1v2_cam has 0v

pp1v2_cam is shorted to gnd. i'am checking what is shorted. could be bad u3900.

i'll need to remove L3901 to see where is the short.
 

Alan.L

Member
replaced u3900 from a donor, isight is now back....took me almost 2 hours to reball this bga chip >.<
 

JohnB8812

New member
Amazing you replaced U3900 that's something I'd never attempt lol good job! Caps lock light sounds like bad keyboard to me. Tried another keyboard?
 

Alan.L

Member
lol thank you, this ain't my 1st time.
it's actually easy than it sounds. just reball and finding a working U3900 from a donor takes a lot of time. 3 out of 4 U3900 from donor boards were bad, i'll get a stencil for next time.


just tried another keyboard, the cap lock light still didn't work, then i tried another trackpad and it worked! thank god. i won't have to replace the keyboard
 
Last edited:
Top