820-00165-02 - Seems to be NO BRAIN

mushr00m

Member
820-00165-02

Fan Spin = OK

ALL MAIN RAILS ARE PRESENT AND AS IT SHOULD
I ALREADY REPLACE BIOS IN ORDER TO GET IT WORKING NO SUCCESS
CPU GETS HOTS

Tried to check external image.. also NO IMAGE
 

mushr00m

Member
Did you check USB activity too?

PLT_RESET_L comes high?
Any history available?

Actually when I plugged external hard drive the light turns on... but it seems energy light not working light, when I plugged on a working machine it turtns on and then starts blinking as it reads the HD

PLT_RESET_L = 3.32V

Customer left a bottle of water opened with the computer... so it was water damage and when I opened I saw it around DC-IN board to be honest... But already tried another DC-IN board
 

2informaticos

Administrator
Staff member
Damaged caused by corrosion.
Inspect all SPI Bus Termination resistors and their traces.
Clean/remove J6100.

Did you get the BIOS file from the forum?
 

mushr00m

Member
Actually I replace the BIOS with another one from the same board number of a working board. So BIOS is not the issue right? I will check everything related to the SPI Bus Termination as you said
 

2informaticos

Administrator
Staff member
That BIOS has dirty ME region, but is not a reason to avoid the boot.
Inspect for corrosion under microscope.

You can try to heat PCH area with quality flux; may have accumulated crap underneath.
 

mushr00m

Member
Sorry my mistake this board did not have any water damaged I make confusion the behavior is as descripted above except water damage.

Measure all the resistors on the SPI BUS SERIES TERMINATION and all of them and giving the number according to the schematic
 

mushr00m

Member
Which resistors should I measure on the CPU/PCH line.. Can you give me better hints I will try my best to find and measure all of them
 

2informaticos

Administrator
Staff member
Could be one from 100 resistors.
No clue apart of classic tests.
Just in case, check all PECI related components.
Also check all L/C blocks next the CPU; near the board edge (1V05 rails).

We have several posts describing how to heat BGA chips, in case of accumulated underneath crap.
Remember, you don't need to melt the balls.
180-200 degrees for 15-20 sec should be good enough; chip temp, not hot air station settings!
 

mushr00m

Member
PECI 2 resistors are FINE
Not sure what are all L/C blocks

I only do have hot air station (Quick 861DW), Is it possible to heat the CPU with it?
 

mushr00m

Member
Got it!

Visually inspecting everything seems normal. Are you advising me to measure voltage on those area? All coils and those BIG caps?
 

mushr00m

Member
Everything around L/C block are fine and giving the right measurements in voltage!... I put some rosin and notice that the CPU gets hot on the bigger rectangle at the left part of it
 
Top