820-00165 not recognising the ssd, fan spins and chimes.


New member
820-00165 no ssd detected. wifi works, it chimes, usb mouse powers up, fan does not cycle. im getting voltage to the ssd coil. main rails appear to be ok.

History, Liquid damaged but was ultrasonicly cleaned by previous tech. C1053 Pin2 GND was corroded so i ran jumper to C1043 Pin2 GND.
U5800 has been messed with but dont think this has any affect, i could be wrong. U6100 looks like its been reflowed as it has hallmarks of a tech who uses no flux, it seems okay. ISL6259 has had its R7121/2 resistors replaced. and Fuckme the smc silicone is gone! LP8550 has obviously been changed too. all in all this system looks pretty healthy. no burnt points. Oh JTAG is missing.

any assistance on where to start would be great. ill start measuring the rails again.


New member
Ive tried to factory reset it but it hangs and does not go any further than connect to wifi and apple logo loading.

after double checking some rails it appeared that i was not getting pp3v42_g3h it was reading 2.19v and flucuating. u7090 voltages were screwed so i replaced it and now pp3v42 is present but still no SSD showing up. ive tried with a good known ssd with os already loaded but still no detection.
Last edited:


Staff member
All good there.
Did you try other SSD, or this one in other machine?

Check if PP3V3_S0SW_SSD_FLT arrives to J3700.
Also check SSD_SR_EN_L and all capacitors from data lines.
Pay atention to U3710/11 too.