820-00281 A1707 missing PP3V3_SUS


I got this board repair witch original issue was full shorted PP1V_PCH_REG_R. Traced that up to the PCH. Customer stated liquid damage but I don't see liquid anywhere.
I replaced the PCH and short gone, cleaned also ME.
When I power up the board I get 20V 90mA. I am missing PP3V3_SUS.

At U8200 load switch I get PP3V3_S5 (3.3V) and also the enable (ON) signal PM_SLP_SUS_L (3.3V) but I am missing PP3V3_SUS.
I replaced the switch and still the same.
I verified the missing rail for short and nothing was wrong compared with good board, I verified also continuity between the output load switch and other point and found nothing wrong.

Out of desperation I decided to jump PP3V3_S5 and PP3V3_SUS and the board worked just fine.
To me it's a good sign for the pch soldering but I have no clue what is wrong, maybe load limit protection?


Staff member
U8200 should deliver 3V3 out if gets 3V3 input and enable signal.
Try another chip; be sure to get good solders.


Thanks 2informaticos, it ended up the U8200 from the donnour was also faulty! I found another one from A1706 and everything is fine now!
After a long and risky pch job replacement I was a little bit discouraged with the second fault...