820-00840 - thunderbolt peripherals isnt working on the USB-C port (B)

Alan.L

Member
charging is working on both ports, USB thumb & 2.5" external drives is working both ports.
but when i try plugging a Belkin thunderbolt ethernet adapter that is closer to the screen hinge isn't working. however, the top port is working with the thunderbolt ethernet adapter.
same when i use an apple multiport digital adapter.

i don't have another 820-00840 so i don't have one to compare measurement.

any idea. thanks





 
Last edited:

Alan.L

Member
I've replaced u3200, it's still the same.

then i went ahead removed the shield :




found a blown D3414 diode




I've removed this ESD protection diode, it's still not working.




top port still works

 

Alan.L

Member
found OL in diode mode on XB_D2R_CONN_N (should be getting around 0.344v)

R3476 is 0hm so its good.


so either USBC_XB_D2R_N to U2800 trace is bad or U2800 is bad.
 
Last edited:

2informaticos

Administrator
Staff member
If D3414 was the burnt ESD diode, then likely bad U2800.
If no need to use both ports at same time, leave it as is.
Recommend an USB-C hub to the client, just in case.
 
Top