820-00928 faulty vram?

dudipupan

Member
Hello again 🙂
I think i just have another Memory issue.
The MBP boots completly after trying it many attempts. It powers on but there is no backlight or display. When it is able to boot it crashes after few minutes (see picture) freezing and faulty display.
So i think it is the VRAM, am i correct? 20210108_210900.jpg
Is there a way to find out which of the Chips is failing?

Thank you and best regards
 

dudipupan

Member
Can test it on monday. Have to wait for the delivery of an USB-C adapter. What do you expect to see on the external screen? If it boots normally on the external?
 

2informaticos

Administrator
Staff member
You must see if the problem appears on iGPU, or discrete GPU.
Once external monitor is connected, discrete GPU is automatically enabled.
 

dudipupan

Member
So i got a adapter now and tested it with an external monitor.
It's getting always harder to boot (more attempts needed) and most of the times it boots with full fan spin and no display and no backlight- independent from trying it with external monitor or without 🤔
 

dudipupan

Member
Already did that earlier - no errors occurred.
When i'm lucky with external monitor backlight shows up but no signal on external and black screen on internal display.
 

dudipupan

Member
So tried it for 1 hour to get into diagnostic mode. Most of the time no USB activity, no backlight and no display. Sometimes it started with usb activity and backlight, freezing in black screen (usb activit stopped) and shutting down after few seconds. 1 time i successfully started diagnostic mode but trackpad was not working. Now it shows low battery even with PSU connected 😄🙈
 

dudipupan

Member
Didn't tried to reball the smc yet. But today i was able to boot and it worked without errors until i unplugged the PSU. The MBP mmediately freezed - no trackpad, Touchbar was frozen, etc. The Fan spin was on max all the time.
 

2informaticos

Administrator
Staff member
If board starts with max fan speed from the first moment, that could be a sign of SMC bypass starting mode.
 

dudipupan

Member
Yes it's always powering on with max fan spin. Whhat could be the reason for it to start in bypass mode automatically all the time?
 

dudipupan

Member
SMC_RESET_L is always high - even if powered off.
SMC_LSOC_RST_L also always high even if powered off.
No reaction on triggering SMC_ONOFF_L manually - independent from keyboard connected or not.
 
Top