820-01521-a water damage around U7650 2018 Macbook Air

Hello all, I got a 2018 Macbook air that had some corrosion around U7650. Replaced U7650 and cleaned with ultrasonic cleaner and now it has 20v and .12a at the charge ports but still no boot. Below are the voltages I still do not have:

PP5V_G3S 0v - applied 5v on this line and the fan goes fast and the speed of the fan will sometimes surge up and down a little.
PP5V_S5_LDO 2.5v
PP3V3_G3S 0v
PP1V8_G3S 0v

All other rails are good and checked for shorts on all the lines above and none are showing a short.

Unplugged battery, no change, still no fan.

Also on the USB voltage tester, the amps will fluctuate a little, .12a to 0 amps every 2-3 seconds.

Just curious if anyone has some clues of what I am missing?

As a side note, with me replacing the U7650, does the T2 chip have to be synced with that chip now? Also before changing the U7650, it was the only chip that was getting hot to the touch, and thus I thought it might be the cause of the issue and because there was a lot of corrosion around this chip.



Staff member
looks like still have a problem with U7650.
Post some voltages; pins 23, 12, 13, 22, 29, 21, 4.


23 - 12.3v
12 - cycles between 0v-2v
13 - cycles between 0v - 2v
22 - 3.3v
29 - cycles between 3.2v - 1.2v
21- cycles between 2.2v - 0v
4 - cycles between 0v - .04v

Hope that helps.

Sorry, forgot to mention no shorts on any of those pins.

Ok, found out after looking more closely and comparing my donor board that I robbed the U7650 from, that somebody has been here before. About 8 caps were either out of place or the wrong ones. So after transferring everything over from the donor board that was around U7650, I now get the board to boot. I have 19.8v and 2amps at my usb meter. All my previous voltages are now there, but now I have no video on the screen or on my remote monitor and no caps lock light. But I can reset the T2 chip via right shift left control option and power button, and my usb meter will shut off and come right back on at the same measurements above.

What is my next move?

Last edited:
Thanks, the only other working macbook I have on hand right now is a 2016 12" Retina, do you know if that will work for DFU restore or do I need another macbook air 2018-2019? I'm picking up today a previously recommend apple thunderbolt 3 cord from Best Buy.



Staff member
It shoukd work, but read all the info about T2 firmware recovery on the forum.
Many people had problems and needed many tries...


Staff member
Before going to DFU restore, inspect the board for knocked off components.
If someone messed up the board before you, may be waste of time now.
Yes, checked as best as I could, visually looks good. I seen some other posts about no cap light and no usb function, I have neither. When I first plug in thumb drive the light will come on for 2 seconds solid and then never blinks or stays lit after that. Tried both ports still no usb functions.

Also just noticed that when I force this to shut down by holding the power button down, it will restart itself (can hear the fan spin up and trackpad feedback). Update: Disconnected keyboard/trackpad and stopped restarting on its own. However with another working board installed, it did not restart on its own.

Also just as a note, it will not go into DFU mode, but maybe because I have no USB functions??

CPU issue? Where would I start to measure at for no caps light and no usb functions? Thanks
Last edited:
Before I started to check the coils, I went ahead and put some good flux around both CD3215 chips and heated enough to get get rid of any possible liquid under the chips because I did not know how bad this was damaged before I got it.
Now after doing that I lost the 20v at the USB meter and now I can only get 5.14v and .35amps steady. Before there was always fluctuating in the amps.
So i went ahead and tried DFU mode with another 2018 MBA and tried several cables and never went into DFU mode.

So I went back and and measured the pins you asked to measure on U7650. Now there are no volts on any pins except for pins 23 and 22 they are the same.

So do you think I might have killed one or both of the CD3215's?? I went ahead and ordered more of these since I was out of stock.

PP5V_G3S is now 0v (before heating up those chips I had 5v) except if I plug just the battery into board and leave the usb charger off I get 5 volts back on that line and if I plug the USB meter back in with the charging cord, the usb meter will not even light up until I unplug the battery. That was new to me, so I must of really screwed up those CD3215 when I heated them up is my guess.

I still have 12.3v on PPBUS_G3H and 3.3v on PP3V3_G3H, PPDCIN_G3H 5.14v. No shorts on any lines still.

Anything else to check before I get those chips?



Staff member
Reballing CD3215 chips should be good enough in your case.
Be sure all traces are good and nearest resistors too.
While checking the traces, I went ahead and removed U3100 CD3215 chip and saw that the 2 pads under the chip were missing, all the others were intact. The schematic says they are the following:


According to my schematic those lines do not go anywhere else. Or is this board screwed then?