820-01521-A

Ictc

Member
Got this machine that doesn't boot up but charges the battery. Non liquid spills at all, the board look very good.
I get 20v on both usb C adapter voltmeter and most of the power rails seems to be solid except for the cpu s0 related power rails...
CPU heatsink gets little bit warm but pressing power button does't seems to do anything.
Any suggestions? What to look at next?
 

2informaticos

Administrator
Staff member
No liquid, but there should be an history.
However, inspect audio board for liquid sign on both sides.

Try DFU revive.
 

Ictc

Member
Sorry, didn't get a clear picture from the customer. "Suddenly It just stopped to boot...".
I entered DFU, tried revive, no change, than tried a restore (they have a data backup...) finished with a big padlock symbol on the configurator 2 window which I definately ignore the meaning of (is it locked? in wich way?). Nothing changed. Still no booting up. I inspected the audio board wich appears to be fine with no traces of liquid spill and also no shorts on the main caps. The bottom side still well coated and didn't feel to screew it up with furthure investigations at this time. When battery disconnected I get 20V/ 0,04 amps reading. When battery is connected I get (on both USB-C ports) 20V 1,74A reading from the voltage meter.
 

2informaticos

Administrator
Staff member
If stays at 40mA, the board doesn't turn on.
Do you get any voltage at L7670?
If not, check pin 4/U7650 level.
Check for short any big coils and all secondary supplies.
 

Ictc

Member
yes solid 5v on L7670
and 3.3 V on L7690. Get also 12V on L7030 with no battery and when battery connected decreasing 4,5V during charge (charging normally I assume...)
The customer said she previously nstalled Big Sur, may be the issue came after a furture update of the os? She also brig it to an apple authorized service provider as soon as it happened and they offered her motherboard replcement for 400€...
 

Ictc

Member
by the way is it normal that in configurator 2 the macbook air is recognized as an Apple Controller? Just performed a new restore ended up with another padlock symbol ...???
 

Ictc

Member
No other hints? Should I reallly let the customer bring this machine to Apple for a mobo swap?
 

Ictc

Member
Once I press PWRBTN pch_pwrbtn_L goes low. That means PHC knows at least that have been triggered to power on. What next?
 

2informaticos

Administrator
Staff member
Any power supply which sends power good signal to ALL_SYS_PWRGD, should be then present.
Now U7800 is used to generate that signal, but it considers all mentioned voltages.
We don't have direct connection between power good signals, like in old platforms.
 
Top