820-01598 works only with battery

JdYoda

New member
Hello everyone.
Got this laptop yesterday, castomer says "mac doesn't charging and external usb drives can not be recognized"
Mac still powers on, everything works, exept usb-c potrs. With plugged in charger usb-c meter shows 5 volt steady on one of the ports, and 5 volt rebooting every 2 seconds on other port. No traces of liquid or corrosion on board.
I found out that PP3V3_UPC_XB_LDO is shorted. After changing U3200 (CD3217) both ports has stable 5 volts with no rebooting. Then i changed U2980. Now Im getting 20 volts, 0.05 amps, board not booting, PPBUS_G3H 12.2, SLPS2R/AWAKE signals present, PP3V3_S5 missing.
With battery mac still turns on, and external devices can be recognized now. But still not charging.

Changed U7000, Q7030/40, checked all resistors around u7000 and both CD3217, they are all fine.

I'd appreciate any advice
 

2informaticos

Administrator
Staff member
U2890 has important information; don't see U2980 in schematic.
There is USB-C firmware.

So the Mac was working before with battery and now doesn't work at all?
 

JdYoda

New member
It still works with battery, and now it recognizes flash drives and other external devices. But doesn't recognize the charger, and won't start with charger only when battery disconnected
 

2informaticos

Administrator
Staff member
I'm not sure, please clarify.
It works with battery alone and charger alone: doesn turn on with both connected?
Post PPBUS_G3H voltage with both charger and battery connected.
Check Q7030 and Q7065.
 

JdYoda

New member
Sorry for my english :)

If battery is connected without charger - mac turns on, not recognizing charger, not charging the battery. Other functions works good. PPBUS_G3H 10.6 volt
If battery is connected and charger plugged in - all same
If battery disconnected - mac doesn't turns on, 20 volts, 0.05 amps, pp3v3_s5 missing, awake/slps2r present, PPBUS_G3H 12.3 volts

Q7030 already changed. PPDCIN 20 volts, CHGR_GATE_Q1 41 volts, CHGR_GATE_Q2 0.2 volts
Q7065: PPVBAT_G3H_CHGR_R - 12.2 volts, CHGR_BGATE - 12.2 volts PPVBAT_G3H_CONN - 0
If battery is disconnected - Q7065 should be opened? Because it's a P-channel, and the gate is high, so it's closed. I changed U7000 already twice. C7064 is not shorted...
 
Last edited:

JdYoda

New member
Before Q6950
SCL voltage 3.2 volts, 0.8 in diode mode
SDA voltage 3.2 volts, 0.8 in diode mode
After Q6950
SCL voltage 1.8 volts, 0.47 in diode mode
SDA voltage 1.8 volts, 0.47 in diode mode
 

2informaticos

Administrator
Staff member
With both charger and battery connected, charger is not recognized on system report?
Did you try another charger?
PCH_BATLOW_L stays high?

Check LDO_RTC at U7800, with charger only (no battery).
 

JdYoda

New member
With charger connected it is not recognized on system report
tryed 3 different chargers
PCH_BATLOW_L is 0 with charger only, and 0.8-1.5 volts when mac is turned on with battery
LDO_RTC with charger only 1.5 volts
 

JdYoda

New member
U7800 outputs:
LDO_CORE 1.5 v
PP0V8_SLPS2R 0.8 v
PP3V_G3H_RTC 3.0 v
PP1V2_AWAKE 1.2 v
PMU_LDO3_OUT_R 1.8 v
CPU_C10_GATE_L 0 v
PP1V_S0SW 0 v
LDO_RTC 1.5 v
PP3V3_G3H_PMU_VDDMAIN 3.3 v
PP3V3_AWAKE 3.3 v
PP3V3_S5 0 v
 

JdYoda

New member
DFU doesn't help.
But i found something interesting: i puted back original U2890, and 20 volts is gone, looks like this chip is dead, because there was a short circuit before on PP3V3_UPC_XB_LDO. And i decided to try this chip from another donor board.
So i've tryed A1708, A1706 A1989 - non of them is working. No 20 volts. And only U2890 from A2141 is switching to 20 volts, but not charging.
Is there a chanse that there is compability between different boards, and U2890 should be exactly from same board?
Unfortunatelly i don't have this one now :(
 
Last edited:

JdYoda

New member
Oh, my mistake, it's a typo...U2890 of course. I didn't find any. I have a CH341A programmer, do you think it is possible to read the firmware from original chip using this type of programmer? Or i should buy some special tool for this? Im at the small island in the middle of Indian ocean, no chance to find donor 01598 here...
 

JdYoda

New member
Ok, so i've tryed to read the data from original U2890 and looks like it worked. I flash the original firmware to the U2890 from A2141 mac, and 20 volts is gone. DFU mode sucsessfuly reviving macbook, but still not charging, and no 20 volts now with original firmware...Board still turns on with battery
 
Top