820-2530 battery issues


New member
Functions 100% on cord but won't run off/charge battery

I get 1k instead of 2k on pull-up resistors R5281 and R5280, but when i replace with new I still get 1k, and the old ones measure proper 2k out of circuit.

is the board shorting together in that area? or is it more likely D6950 bridging? or maybe those caps there at the edge?
had no signs of liquid damage, just started flaking out charging.


New member
ok really weird, i had this on the shelf for the last month or so and the behavior i described was how it was last time i had it out messing and reading it, when i took it out of client's computer
and now when i tried it all again with a screen it's behaving totally different

still green light on magsafe, but now will not power up off cord or batt. however really interesting is ext usb hd comes on when cord and batt are plugged in, even though machine and fans are off
going to look at charger circuit sense and everything again in a bit


New member
looks like i'm getting 3.44V on 3v3_s5_reg, is that close enough for 3.3?
no pp1v05 reading on L7770


Staff member
Wait a second, if PP3V3_S5 exists, why are we replacing U7200? Please explain thought process here!