820-2850 green light no power


New member
got in a 820-2850 with green light, no orange light with battery plugged in. fan will not spin but does make some glitchy movement when plugged in. i found the c4136 was missing and replaced it, i checked voltages around that area and nothing is giving any volts, c4136, c4102, f4260, d4260 and more all have no voltage. also f7040 is only giving me 1.5v on both pins.


New member
Yes voltage drop to ground on both sides of the f7040.

3.2 ohms on 17-18
20.7 ohms on 27-28
I did just replace the isl 2 times with what i believe tested good but idk.


Staff member
OL and 0 ohms is totally different thing!!!
Forget auto-range multimeter; use manual one on diode scale.


New member
i stopped using it in auto range already,
0.479 v to ground in diode mode, should i measure with red to gnd and black to power or vise versa? i read some were to put red positive to ground and black negative to power when testing ohms just wondering if this is right or not? if i test it with black to gnd i get .0L


New member
no power from battery only. i tried tripping the pads. i just got in another of the same board with the same issue, same readings. i tried it also with the battery and nothing but when i do plug in the power with the battery installed the fan makes slight movement not a spin but movement. I am 95% sure this was liquid damaged.


New member
no worries, i thought that was the case.

i have 2 of these boards same 2.66 with this same issue so i'm going to give readings from both boards here

board 1 - battery only 11v Battery + charger 11 volts up to 13 back down to 11 and so forth.

board 2 - battery only 11v Battery + charger 12.4v solid


New member
voltage on pin 5 of the Q7030

board 1-
power supply only 0v, battery only - 10.4V battery + charger - 18.3v jumping down to 13 range and back up to the 18 and repeating.

board 2 -
io only 0v, battery only 10.4v, battery + charger - 18.3v solid


New member
I just got in a 3rd board like this all 2.66. 820-2850.

Ohms to gnd on ppbus 131.1k ohms give or take.

wont power on with battery or power. f7040 W/ battery = 11v - W/ Battery + power = 12.6 jumps down to 3.7 and back up to 12.6 and so forth.

pin 5 of q7030 battery only =11v battery + power = 3.7 jump to 6.2 and back down and around.

ISL Res on pin 17-18 = 3.4 pin 27-28 = 20.5

Really stuck on this one and need to get one of these back to a customer asap.

Any ideas?

Many thanks