820-3437 heat/liquid damage - battery replacement


New member
Hello all,
I have loved watching the youtube channel and have had a fun time tinkering my self on some macbooks.
To cut to the chase, I have an 820-3437 that came in because it was not charging the battery. After opening up the system, I found some nice sugary mess on the back side of the board in the C1047 area. I also found A LOT of happy little solder balls sneaking out of many caps for the PPBUS_S5_HS areas (pretty much every cap on the CPU side of the board except for C7130-31 and a few in that area.

After gently cleaning with a toothbrush (I mean gentle - I didn't want to become a statistic that Louis talks about so much) the board no longer powered on... Great.

So I got to the trouble shooting. Had no G3H. Ended up replacing all the bad looking caps due to the escaping solder balls - Still no solution, Changed charger in board - no change. Swapped back old board and FM - it worked again. So I cleaned the connectors of that flex cable some more and no more problems with the onewire. Now I was back to the original problem of the battery was saying it was 0% and only working on the wall power.

Did some trouble shooting, replaced a few components/voltage rectifiers that the caps could have damaged due to heat, checked the feedback resistors, change them cause I wanted to be sure. Finally swapped out u7100 - still same problem. I had dropped the new u7100 before installing it so said, ok, lets try again. Swapped with another new one and battery was reading that it was charging/full.

Ran ASD and found a bad sensor in the battery pack (-27degrees on one of them) Just installed a new battery now.

SO, where I am at is, after installing a new battery, plugging in the charger displays the orange charging light, but the computer says 100%, unplug the charger and the battery jumps to about 93% Is this a battery calibration problem? I don't think so personally.

Other thing to note/question.
PPDCIN_G3H is 15.10v on pin 1 of Q7180 (inrush limiter) and 14.57v on the output pin 4 (originally this was not getting its signal from U7100 to open)
Q7130 has the same 14.57v on pin 2 but only 8.18v on pin 7. Well below the 8.6 listed in the schematic.

I have a feeling this is the problem as only 8.18v is going out to charge the battery max? Or is the sense circuit doing its job and thats all the 7.3v battery needs to max charge?

If this is a battery calibration thing, I'm all ears! This is my first battery swap for a macbook and wont be my last.

Have a great day and sorry for the mess of a post.


  • photo1199.jpg
    377.8 KB · Views: 0


New member
Something I just noticed,
In the operating system the battery says 96% "battery is Charged" but i have the orange light still on the charger. I have left the system plugged in and off for about an hr with the new battery and the green light never came on.
I just let the battery drop down by 1% an plugged the charger back in. System still says Battery is Charged. Possibly a current sensing problem?


New member
Thank Gurmon, I did mention I installed a new battery. I tested 2 new batteries actually, same problem.
So, I made a rokie mistake and somehow, after testing the current sensing circuit about 10 times - R7121 was sitting at a comfortable 30.2ohms... No beno, Changed it out again with a brand spankin new 10ohm 5% and still was not getting charge. Everything looked good outside the U7100, current sense circuits, battery was comunicating with SMC, other variouse components for charging, so my gut told me 3rd time is the charm.

Changed out U7100 again, and now all is happy. Seems the brain is the best tool :)

I am charging the system now and finally got that happy green light I have been wanting.

By the way, is that 15.2v and 8.2v normal for the air? Its quite different from the schematics and I haven't opened any others up yet. Also, any input on the balls flowing out from under the caps?


I guess this could be a case closed, but would love to hear some feed back about those 3 questions I have.


New member
By the way, is that 15.2v and 8.2v normal for the air? Its quite different from the schematics and I haven't opened any others up yet. Also, any input on the balls flowing out from under the caps?

So that's a no to some feedback of those questions? I tried to make the question pretty straightforward - or is this when I should make another forum post? Even if it is related to this repair?


Staff member
8.15v on PPBUS_G3H means the SMC is not running. The SMC(U5000) talks to the ISL6259(U7100) on an SMBUS line that can be pulled down by a bad battery, bad ISL6259, or a bad SMC, and tells the ISL6259 at some point to go up to 8.5v. If this were the case that PPBUS_G3H were 8.1v I doubt the machine would be charging or even seeing a battery at all.

Random solder balls around capacitors is no good. I have no other thoughts on this.


New member
Thank you for the insight and answers Louis! I did really like your video on the charging circuit and that is why I went and checked the current sensing resistors again. I probably burned it while changing out that ISL6259 because I am still learning the techniques. The system passed all the tests I could throw at it before it left my door and the client has been very happy with the repair.