820-3437 Works on charger but not battery


Hi, I have a 820-3437 MBA that came in as not turning on. (no liquid damage but just didn't turn on one morning)

Found a shorting cap C7431 (PPBUS_S5_HS_COMPUTING_ISNS)
Thought it was going to be very easy as it was replaced and diode tested okay. Turns on now and boots, sees the battery serial etc but doesn't charge it. Also sees the battery at 86% on the original and 20% on the known good.

If you pull the magsafe, it cuts power with a battery connected.
Tried another battery, tried another DCIN.

On magsafe only, I get an initial green light that changes to orange, I get 16.5v on Pin 2 & 3 of D7005. PPBUS_G3H is 8.52v

On battery only, PPBUS_G3H is 1.4v

Removed F7140 to diode test pin 1 and 2.
Pin 1 = 0.125v
Pin2 = 0.450v

Do I have a short somewhere on PPVBATT side of F7140 or have I gone the wrong direction for fault finding?
Last edited:


R7150, 7151, 7152, 7120, 7121, 7122 all test fine

CSON,CSOP 17-18 on U7100 = 3.1ohms
CSIN,CSIP 27-28 on U7100 = 19.9ohms
SDA,SCL 10-11 on U7100 = 3.99k
Last edited:


Staff member
Be sure R6950 is OK.
Also check if Q7155 is not brohen; post its voltages, on battery only.

"Removed F7140 to diode test pin 1 and 2.
Pin 1 = 0.125v
Pin2 = 0.450v"
Good readings...


Thanks for the reply JohnB8812 - Yeah I forgot to mention I checked 7005/6 they both check out fine 9.9ohms, 4.8ohms

Thanks 2informaticos
R6950 is good at 10.01k

Q7155, battery only, not in chassis (F7140 still removed) =
pin 5 = 3.197v
pin 1,2,3 = 3.178v < took a while to climb to this voltage
pin 4 = 2.302v < took a while to climb to this voltage


Well, someone switched my good battery and I wrongly assumed the voltage was being pulled down :eek:

Turns out it needed a new battery :p

Sorry for wasting your time folks.. thank you for the help