820-4924 Orange light, missing ALL_SYS_PWRGD

EsteTron

New member
820-4924 came in with no signs of liquid damage and no power on and no mag light. I left the board alone for 2 days while I worked on other repairs, and by the time I got to the board, I first plugged in magsafe and got a orange light. Light disappeared after a few seconds. I then removed magsafe and battery and held power button down for 10 seconds, reconnected power and got orange light and was able to boot machine to login screen. I decided to leave machine alone to charge up battery and noticed mage safe disappeared after a few minutes.

Now device has orange light, and no boot. First thing I checked was All_SYS_PWRGD and noticed it was not present.

PP3v42= 3.42v
PPBUS = 12.6v
PPVRTC_G3= 3.V
PPVIN_S5= 12

PP5V_S5 = 5V
PP5V_S4 = 0
PP3V3_S5= 3.3V
PP3V3_S4= 0

It appears my PM_SLP_S5_L is not present so S4, S3, S0 rails are not present. Checked up the line and found PM_SLP_S5_L is created by U0500, so I looked into PM_PCH_PWROK and noticed it wasn't present either. I then noticed that PM_PCH_PWROK is created by the U1950 Logic Gate, which is enabled once ALL_SYS_PWRGD is present.

I feel like I just went in a giant circle and was hoping for any advice on what I should be looking at next.

Thank you in advance.
 

2informaticos

Administrator
Staff member
ALL_SYS_PWRGD will only appear after all secondary voltages are generated; les CPU one.
If board booted in SMC bypass, this means a SMC sensor issue.
Does it still start in this mode?
If yes, start checking VD0R, VP0R, IP0R and IPBR output sensors.
 

EsteTron

New member
Thank you for clarifying that for me. I had a feeling that is what I was dealing with, but I wasn't sure. Okay so I tried the SMC bypass and the board pulls 0.200 Amps from DCPS. Power rails are being pulled down.

PP5V_S5=5v
PP5V_S4 = 4.8v
PP5V_S3 = 2.35v
PP5V_S0 = 2.3v
PP3V3_S5 = 3v
PP3V3_S4 = 3V
PP3V3_S3 = 3V
PP3V3_S0 = 3v
PP1V5_S0 = 1.5v


Since device is not booting all the way with SMC Bypass, I believe I need to resolve whatever is pulling PP5V down first before looking into SMC Sensor.
 

2informaticos

Administrator
Staff member
You MUST check the SMC sensor involved in power sequence.
Because is the reason board doesn't even start the sequence...

"PP5V_S3 = 2.35v"
I suppose measured on SMC bypass mode.
In normal mode do you catch a pulse there, at least?
Try triggering SMC_ONOFF_L.
If yes, son't need to check above mentioned sensor (previous post).

Seems to have a problem with 5V_S3 power rail.
Post resistance to ground at L7520.
 

EsteTron

New member
Yes, PP5V_S3 = 2.35V in SMC Bypass mode.
In normal mode, there is no pulse, even after triggering SMC_ONOFF_L
L7520 Diode Reading= 0.392v

All measured in normal mode
VD0R = 2.4v
VP0R = 0v
IP0R = 0.034v
IPBR = 0.063v
 

2informaticos

Administrator
Staff member
Try to solve 5V_S3 problem starting in bypass mode.
Check R7520-22, C7524 and R7544.
Post exact value for P5VS3_EN.
 

EsteTron

New member
R7520, R7521, R7522, R7544 are all measuring correct resistance. C7524 is not shorted.
R7520, R7522= 2.35v
P5VS3_EN = 2.9v
 

EsteTron

New member
Sorry for the long delay. I did not have access to post on the forum for some reason, but I am back on now. I replaced U7501 and now the board will power on in SMC bypass mode will all rails present for a second then turn off, then power back on again after a few seconds, then power off again. I checked the current sensing resistors on ISL6925 and I am getting 21 ohms between Pins 27 and 28 on U7100, which seems normal, and 4 ohms between Pins 17 and 18.

Without smc bypass, PM_SLP_S4_L is missing. I am currently looking into the VRTC, BIOS and SMC sensors. Any other suggestions on what I should be looking into?

Thank you
 

EsteTron

New member
Thanks. I am looking into to that now. I did make a discovery and noticed there was an issue with my MagSafe 2 cable that I have plugged into my DCPS. I replaced the MagSafe 2 cable and now I draw .025A upon connecting to board and spike to .400A for a split second, and drop back to .025A.

With new MagSafe cable connected, I get 3.3v on PM_SLP_S4_L for a split second.
Split second pulse of 3.3v on PM_SLP_S3_L when connected.

Will report back after looking into SMC voltage sensors.
 
Top