A1502 emc 2835 820-4924-A battery not detected, no fan spin on power up.


New member
Good morning all.
I know I am probaly going to get trolled here and the problem is more than likely so evident.... but I dont seem to be able to locate the issue or what I am looking for as I am getting strange readings. So as follows:-
pin 7/8/9/16/17/18-- gnd
pin 4/13-- alternates 3.42v - 4.78v and various incarnations close to either end ( i.e. 3.42v may be 3.429/ 3.427/ 3.426 and 4.78 may go 4.47/46/48) never steady
pin 5/14 -- 3.42v static
pin 6/15-- 0.00v
pin -- nc
pin 1/2/3/10/11/2-- initial shows 12.58v then drops to 3.419v then rises to 12.58v then drops to 3.419v ongoing

even though openboardview and the schematic show 4/5 as NC there is definatly voltages there.

When I turned the board over and looked under the scope D7050 was cracked, so I replaced this. C7050 and C7060 seem OK.

Here is the issues, MBP came into me initially after having a bottle of Ribena poured over it. Refused to power on even though LED on magsafe was there. Went over the board and replaced a few components and cleaned. It then powers on with no problem with exception of the battery was not detected or charging and the fan would not spin initially, however after about 5 mins of use it did spin. Went over the voltages at J7050 and all were correct as far as I could see. A new battery ( genuine ( aparantly)) was purchased and installed. All worked fine, battery was detected and charged to 100%. The MBP even though the fan did not spin initially and did not over heat worked fine.

It has now come back again with the battery not detected and not charging, the fan issue still persists but the MBP boots and works perfectly despite these issues.

The voltages I have listed above are not the same readings as before the battery change. The reason I mentioned the fan is it may or maynot be connected to the issue.... I just do not know.

From my limited experience, I feel the issue is the SMC but I may be wrong.

Can anyone enlighten me as to what the readings should be and what I should be looking for.
Many Thanks.


Staff member
"the fan issue still persists"
No fan issue at all, is the normal behaviour for this model...

"schematic show 4/5 as NC"
Not true; 4<-->13 and 5<-->14, as per schematic.

Try known good battery, even old; just for test.
Post resistance to ground on SCL/SDA lines.


New member
i will be back on this on Monday 2informaticos so will get the measurements you require then. The old battery was showing as not detected or chargeing, and when the new one went in it was working OK for a couple of weeks. I will get another battery in the meantime just to discount the new one. Old battery has been disposed of.


New member
sorry for the delay in coming back to you, something really odd is going on.....
So, I have an Isotech IDM 505 Multimeter.
When I test for a short to ground on pins 4/5/13/14 i get a quick beep and the display shows O.L and on pins 6/15 i get no beep and O.L on the display. Now I am expecting to see a reading in KOhms. I fell in to this trap before where i read in resistance mode and not diode mode so made sure I have it correct this time. To make sure, a colleague of mine that does TV repairs did the same checks with his Fluke 115 which yielded the same results.

For good measure I tested for a short at pin 11 on u7100 for smbus_smc_5_g3_scl which again quick beep and 0.L and pin 10 on u7100 for smbus_smc_5_g3_sda again with short beep and 0.L. Again R7050 pin 1 for sys_detect_l yields no beep and 0.L

Every time I have seen our friend Louis test for short to ground there has always been a reading other than 0.L
My TV guy reckons there is no short.... is this correct?


New member
Oh, hang on, your post says resistance to ground so the readings are :-
pins 4/13= 21.56 kohms
pins 5/14= 21.51 kohms
pins 6/15= 9.99 kohms

Hope I got it right... :)


Staff member
Ohm values are very similar.
I suppose diode mode readings too; better to confirm.
I still recommend to test a known good battery.