A1502 no battery and no fan

Vertx

New member
Hello!, have a board which is 820-4924-A and was after liquid damage. After cleaning and replacing corroded components board turns on, boots, but won't detect battery and fan at all. So far what I managed to measure:
PP3V42 - 3.42v
PPBUS-G3H with connected only battery is 11.04v
PPBUS-G3H on charger 12.25v
Resistor R5380 - 2.0K
Resistor R5381 - 2.0K
Resistor R5492 is only 148K which should be 200K
SMC_RESET_L - 3.37v
PP5V_S3 5.15v

Battery connector under the board was badly corroded (photo before) so can it be that SMC chip needs replacement due to short? Sorry, still pretty unexperienced, hungry for new info, thank you! :)
 

Attachments

2informaticos

Administrator
Staff member
"PPBUS-G3H on charger 12.25v"
SMC doesn't talk with ISL6259.
I bet you have corrosion problem on SCL/SDA lines of battery bus.
Check voltage and resistance to ground (diode mode) on these lines.
I recommend you remove and clean, or change directly battery connector.

BTW, recently similar case got 7V on SDA line, because of corroded connector.
That suppossed burning 3xISL6259 ...
 

Vertx

New member
So, after replacing battery connector, U7100 and just after SMC reflow board detects and charges battery fine, but fan is still inactive and cpu reaches temp up to 90C, but on apple diagnostics at the end it spins. Thinking that SMC might be bad and needs replacement. If that would be case, could I reball and fit SMC from 820-3476-A to my 820-4924-A?
 

Vertx

New member
It's been a while with this device, but after doing some more tests just saw that macbook fan spins for one second then stops, after 6 seconds break starts again and stops and so on.. Any ideas guys? (in case just got my 820-4924-A donor board so will have plenty of components to spare)
 

2informaticos

Administrator
Staff member
On this board, fan doesn't start from the beginning.
It will spin later, when the CPU gets really hot...
 

Vertx

New member
Haven?t mentioned that CPU reaches 90-95C while watching youtube in full screen, but as mentioned fan just spins for second and stops and then same again after few seconds. Temperatures not going down due to fan being ?lazy?. Did tests on same model, when CPU reaches temp between 80C fan kicks in and it cools to reach 40C, mine just tries to spin and stops :)
 

2informaticos

Administrator
Staff member
Install Macs Fan Control and manually set the fan for the CPU die.
Let see if fan stays spinning.
Did you try known good fan on this board?
 

2informaticos

Administrator
Staff member
CPU Proximity temp appears to be less than 80 degrees.
Set Macs Fan Speed for CPU die, as both have high temperature.
If still bad, check R6061/64/65 and Q6060, as their solders and traces too.
 
Top