A1706 820-00923 Bootloop with "EB|LOG:EXITBS:START" displayed in Verbose mode


New member
Hi, very first post on this nice forum. Read a lot here, but I've never seen something equal to my mystery. Hopefully it has a solution...

So, after connecting charger, Apple logo after a while, no progress line. After 5 secs reboot and so on.
Switching to VERBOSE mode gives more info (see picture), but always ends up with EB|LOG:EXITBS:START. Reboots and always the same.
Macbook reboots when PM_SYSRST_L becomes low for a second.

Trying to enter recovery gives backlight, but no more text, nor Apple logo
Connect USB with OS, press option and switch on, gives USB activity, but again only backlight, nothing else. Just like with recovery, the whole thing reboots after a while.
Measured every tension, everything is present.
PPVCC_S0_CPU is 0,6V when Apple logo is displayed, just after reboot it's 1,1V.

Maybe some useful history of this board...

The owner dropped the Macbook from a table. After that, nothing, but CPU became very hot. When this thing became very hot, blowers goes blowing. After some "jumping", board w/h battery pulled 666mA steady.
Reballed CPU, same behavior.
Reflowed SMC which gave backlight at the first try, but while booting Suddenly just 20mA steady on my USB-C meter. C1061 on PP1V2_S3_CPUDDR became shorted (coincidence?). Replaced and I've got backlight again and the Apple logo which always reboots.

SMC bypass mode doesn't work I think (blowers don't start to blow at full speed).
When I disconnect touchpad, reboots are faster. Such fast that I've nothing more on the screen. In that case gives an SMC reset (reset pins on the board) an Apple logo once, until the first reboot.

At last attempt, I've reballed SMC, the same behavior.

Spent already days on this...

Thanks for the info!



Staff member
First of all, welcome to the forum!

Dropped machine can be nightmare.

Test the board alone on the desk; nothing connected, only charger.
Just monitor CPU core voltage and see if maintain 0.6V at the time you've detected restart before.
If steady, check for external video.


New member
When the board restarts, 0.6V becomes during 1sec 1.1V; 0.5 sec 0.9V and again 0.6V.
7 secs later restarts again. 1 sec 1.1V; 0.5 sec 0.9V and again 0.6V and so on and so on.

(As previously mentioned does this board has other behavior with disconnected trackpad. eg Faster reboots.)
So, with external monitor and the board on the desk and nothing else connected, no picture, monitor keeps sleeping. Also no USB activity at all.
When shorting SW5227 (SMC reset), CPU core becomes 1.1V for a while. When this drops to 0.6V, external monitor switches on, but gives no picture. 7 secs later reboot and the same story as before shorting SW5227.


New member
isn't it possible to narrow it down? I've plenty of time to find this out. The owner bought already a new laptop.

If you enter this "error code" in Google, it's very known in the Hackintosh world.
But I can't find any real meaning of this in a real Apple computer. Maybe this could be a "start" to find it out, if someone could tell me that?

I forgot to mention this: previously I was trying with a good known bios. With the bios chip removed, there're no reboots. With a clear bios from this forum, I only have backlight, no Apple logo, no blinking question mark. But the same reboots.


Staff member
To discard an internal SSD issue, remove J9600 and test again with USB macOS.
You can also check if still restarts in boot menu; without loading macOS.


New member
With disconnected J9600 I only can get the reboots without picture. In de past, I've got once a blinking question mark for 1 sec and reboot with a disconnected J9600
Connecting an USB with macOS and this J9600 disconnected doesn't lead to any picture. Nor while trying to pushing into recovery or hitting the "option" button while booting. Only backlight and the reboots following the same pattern as with connected J9600.


New member
The only way I can get the Apple logo, and in verbose the EXITBS message, is with his original Bios file.

In the mean time, I tried yours from yesterday. Board tries to boot, I've got backlight, but nothing on the screen. After this, again the reboots.
It's exactly the same behavior as I encounter when I store the BIN file provided in this topic:

Maybe I'm completely wrong by thinking this, but I've no experience on this board; never ever worked before on a A1706....

Couldn't this be an SMC related issue?
I think with the board on my desk, charger connected, external HDMI display connected (by using USB-C dock) nothing else, this board should boot and give a MacOS login screen on the external monitor, right?

If yes...

1. With touchpad disconnected, I have faster reboots and nothing on the (laptop) screen. Only when resetting SMC I have one time an Apple logo for a few secs. Touchpad communicates to SMC via SMBUS_SMC_3_SDA, right?
2. SMC bypass doesn't do anything. I expect blowers at full speed.
3. In a few Hackintosh forums, people who had this error had a faulty virtualSMC.
4. Sometimes, but really sometimes, I already forget, but had it again when trying with the bios file, the left blower blows at full speed and the right one doesn't doe anything.

The last thing I can remember myself: when giving the PRAM reset command, I've only the backlights with the reboots, no more Apple logo.
It seems he can't find his startup disk before the reboot happens.
Lucky me in the very first beginning, I've stored a copy of his original Bios. Reprogram this in the EFI chip gives again the Apple logo.


New member
Ok, looking for another SMC. Don't have such a scrap board at the moment; have only an 820-00928

Last question before I'm looking for a donor board: on an eg.A1286 with defective ram, computer gives 3 beeps and doesn't do anything.
What does this board do in case of defective ram?


Staff member
3 beeps point to RAM issue.
There may be bad contacts, or broken solders of RAM slot (usually).
But problem may be on CPU side; like broken DDR data line, broken solders under CPU, or even CPU internal issue.

You should use a DDR3 test card...


New member
I think you don't fully understood what I've meant.

I asked: when in this board (820-00923) the RAM is defective, does it also beeps three times like an A1286 will do.
It's one last "unknown" for me on this A1706 board: what does this when RAM is defective?


Staff member
OK, unerstood now.
Not sure if beeps in this case.
Even old boards will not always beep in case of RAM issue; depends of the problem encountered between RAM and CPU.