A2179 G3H stuck at 1V


New member
Hi all, hoping to get help narrowing down an odd issue.

Board has had liquid damage, and would not boot when it was dropped off. Never had a G3H short prior to cleaning or afterwards. Cleaned and reflowed minor liquid damage, nothing severe enough to cause a short in the first place. Reflowed ISL9240, there was very minor corrosion nearby. Absolutely zero corrosion at CD3217s.

Board booted up fine with no issue afterwards, logged into OS, all functions working as they should. Suddenly while sitting idle at desktop, it shuts off, while on battery and charger. The board was on for roughly 3 minutes before shutting down, computer was fully assembled.

Now the issue is that I've got 5v on my USBC meter with intermittent (not looping) .025A, on either port. Still no shorts, G3H RTC not present, G3H stuck at .9v-1v. R7061/R7062/R7022/R7021 all showing normal impedance, swapped them back and forth anyway with known good board, no change. Changed ISL9240 THREE TIMES :( Same result every time. I've swapped the ISL with a known good donor, it works fine when taken from the donor, and when it's reinstalled back to the donor. Everything I check points to the ISL being the issue, or maybe U6960, which I've replaced as well.

I'm sure something silly is evading me and I missed something, I'm hoping that's the case. Thanks for any input!


Staff member
What is diode mode to ground reading at PPBUS_G3H rail?
There is no voltage, even with battery connected?

Post U7000 basic voltages; P_IN, AUX_DET, SMC_RST_IN, VDDA/P, CBC_ON, EN_MVR, A/BMON.
Check resistance (ohm scale), over C7020/23.