A2251 (820-01949-A) No display on internal or external monitor


Hello again.
Working on a 2020 Macbook Pro.
Model A2251
Board model: 820-01949-A

It has no display on the internal screen or on an external screen.
I tried with another new screen as well.

Customer originally reported when they bought it in that it was slow to start up, and was shutting down after a few minutes.

The Macbook makes the chime sound when you plug USBC power into any of the 4 USBC ports, and the touchpad clicks, so it seems to be working.

I put the unit into DFU mode and a another macbook could see it in Apple Configurator.
I selected the DFU device within the configurator, then went Actions - Advanced - Revive Device.
It got to step 4, installing System, then shortly after came up with a lock symbol.
If I click on the lock screen, the about screen states that the State is "Booted"

I'm not very familiar with using the Apple configurator, by the way.

The customer would like the data, but also stated if there is no other way to get the data, he's happy to get it erased.

I tried to put it into target disk mode, but it doesn't seem to work, as it does not appear in disk utility.

Before I try to do a full restore, which will erase all the data, I am hoping someone may have a suggestion to try first.

Any help greatly appreciated.


Thanks for your advice once again 2informaticos, and I hope you had a good Easter.

The customer was hoping to get the files back, but were happy to not get them, if we have to wipe it to get it going, which I was going to do via DFU mode.

After the Easter break, I again had a look at it, and the unit turned on and displayed correctly!

However, it soon rebooted.
I get to the login screen, I input the password, see the desktop, then within a minute or so it would turn off, then restart again, in a loop.

However, as it felt quite hot, so I stuck a 120mm desktop fan pointing right at the CPU heat sink, and the unit hasn't turned off for nearly an hour now!
I've successfully backed up the users photos, and in the middle of backing up the rest of their files.

Now, I am fairly certain I saw the fans spinning when I was first looking at the unit, but today, I haven't seen them active...

It must be heat related, so perhaps there is a a cracked solder joint, or perhaps some overheating component causing the reboots?


OK, perhaps I make a misdiagnosis re heat causing the issue.
The unit stayed on overnight with the desktop fan on it.
After checking all the data was copied, I then retested it without the fan, and it seems stable.
To check the temps, and the fans, I ran "YES" from the terminal.
The CPU got very hot, both fans came on OK, and the system did not fail.

This must be a fairly intermittent issue...

I started in diagnostic mode, selected I agree, and the diagnostic tests passed with "No issues found"
Reference code ADP000.

Would you recommend a reinstall of OSX?