imac 820-2901-A intermittent black screen

protocold

Member
internal LVDS was torn, along with L9000 and C9020. Someone else attempted a rebuild, but I removed these and rebuild again myself.

Machine will chime, but the screen will be black screen. Sometime it will come up correctly.

Hooked to external monitor which display ok.

what now?
 
Last edited:

2informaticos

Administrator
Staff member
If still comes up sometime, you must have contact problems.
Check J9002 and all its traces.
Do you get stable 12V at pins 27-30?
Also check levels at pins 22 & 31; when the problem appears.
 
Last edited:

protocold

Member
I have verified that there is no continuity problem for J9002 pins. I verified this by measuring the other end of the lvds cable (that goes into the screen) with the pin on the J9002. nothing is short against others. Pin 23,24,25,26 are ground. Pin 27,28,29,30 are tied together to connect to L9000.

Is there any easy way to mount the screen so i can measure this while everything is plugged in?

It is very hard to measure pins when the screen is mounted, but if i take out the panel, the measurement wont tell anything right?

But let me state the value when the panel is disconnected first anyway:
VIDEO_ON = 0v
Q9001 pin 3 = 11.58v
Q9000 pin 4 = 11.81v
Q9000 pin 3 = 11.66v
Q9000 pin 1,2,5,6 = low.. 0.2v to sometimes 1.5v

Does the board communicate with the panel via pin 2,3 (i2c) before powering up the panel? Is that why VIDEO_ON is 0v when I have the screen disconnected?
 
Last edited:

2informaticos

Administrator
Staff member
Sorry for misstyping, I just corrected now; read pins 27-30 instead.

If R9050/51 are not soldered, SCL/SDA no5t used too.
This is eDP display, so PCH monitors DP_HPD_INT level.
12V required for display at least few seconds when machine boots.

No reason to check voltages with J9002 disconnected...
 

protocold

Member
you mean 12v required at Pin 27,28,29,30 for display at least few seconds? But it is generated from Q9000 which is turned on by VIDEO_ON for the 12v?

Does VIDEO_ON come from the screen panel?
 
Last edited:

2informaticos

Administrator
Staff member
This is display port; power must go to LCD first.
It will reply puting high DP_INT_HPD line.
If PCH doesn't detect it, 12V goes off...
 

protocold

Member
ah. ok.. so should I look for power to the LCD then? where should I look? does power come from the J9002 or the inverter?
 
Last edited:

2informaticos

Administrator
Staff member
"Do you get stable 12V at pins 27-30? "
At least in the first seconds.
This voltage must pulse even without LCD connected; in such case, will rapidly disappears, of course.
Voltage remains steady, only if DP_INT_HPD goes high at same time.
 

protocold

Member
no, i didnt even get 12v at all on pin2 27-30, not even first seconds....I have the LCD off... no pulse... (measured with multimeter)

pin 31=3.3v
PP12V_S0_LCD = 12V stable
 
Last edited:

2informaticos

Administrator
Staff member
Mmmmh, maybe 3V3_S0_VIDEO is the voltage required for detection.
But you didn't mention anything about DP_INT_HPD signal.
Also post VIDEO_ON and LCD_PANEL_PWR; screen connected, of course.
 
Top