Macbook Air A1932 No display on external and internal with battery

Hi
Macbook Air 820-01521-2 has no display with battery. i have checked with different battery also but got same response. i am getting display on external and internal both without battery.
there is no liquid split sign on board or damaged component. Also checked with two different good screens.
USB meter shows 1-2 Amp when plug in with battery. it seems, it try to turn on but soon goes to 0 Amp and start taking heavy current(1.5 Amp approx.) looks like charging battery. Tried PRAM reset.
Also not able to login the device. it get stuck at login screen after entering the password and stays at login screen for hours. after that start rebooting at apple logo ion every 5 sec.
What could be the problem? i have no idea where to start.

Thanks
 
Last edited:
Hi

I have tried Revive and Restore both in DFU, After finish line each time i got the second image. System not booting at all. nothing on screen.
But when i unplug the battery and booted with charger only , ?mark was there on screen.


IMG_5360.jpgIMG_5361.jpgIMG_5363.jpg
 

2informaticos

Administrator
Staff member
Something similar happened to me with a machine damaged because of liquid spill on the audio board.
In my case, I couldn't even complete DFU.
But didn't note the battery issue.

Inspect audio flex and board for liquid signs (both sides).
 
Last edited:
I have checked each and every single component on board, there is no liquid damage, rusted or loose soldering component. device shows display without battery and also acting with Command+R going for recovery.
 

2informaticos

Administrator
Staff member
Check exact resistance over C7020/23.
Try to start in SMC bypass mode, with both charger and battery connected.
Also check SMC_DCIN/BMON_ISENSE levels.
 

2informaticos

Administrator
Staff member
I was expecting ohm resistance between caps pins, not diode mode to ground.
Probably good, if still not working in SMC bypass mode.

Do you get external video with battery connected?
Check at least for USB activity then.
CPU voltages present?
 
First of all, Thanks Vali for your help and guidance.
there is no external video or USB activity with battery connected.

These are the CPU voltages which i check with battery connected and without battery, didn't found major difference.
PPVCCGT_S0_CPU--0V
PPVCC_S0_CPU-- 1.132V (without battery PPVCC_S0_CPU-- 0.712V)
PPVCCSA_S0_CPU--0.751V
PPVCCIO_S0_CPU--0.964V

PP1V2_S3--1.2V
PP0V6_S0_DDRVT-- 0.6V present
 

2informaticos

Administrator
Staff member
1.132V at CPU core means board is stuck, doesn't really boot.
iGPU is normal 0V, until high load graphics is detected.

"Diode mode values on C7020- .455V on both ends and C7023- .0545V."
I was asking for OHM resistance between their pins, not diode mode to ground.
 
initially PPBUS_G3H was 12.72 and then suddenly jumped to 12.93V. tried 2-3 time but jumping directly from 12.68V to 12.93V and further no increase in PPBUS_G3H.
 
Top