(SOLVED) 820-01598 bootloop

hello i have a2159 apple logo (bootloop)
itried dfu mode but cant detect by configurator2
got 20v usb meter.
btw board is clean no sign of corossion.
PPBUS_G2H 12.6v
PP3V3_G3H 3.3V
P5VG3S_EN 1.8V
PP5V_G3S 5.1V

PP1V2_AWAKE 1.2v
PP1V8_AWAKE 1.8v
PP3V3_AWAKE 3.3v

PP0V8_SLPS2R 0.8v
PP1V8_SLPS2R 1.8v
PP1V1_SLPS2R 1.1v


PP1V8_S3_MEM 1.8v
PP1V2_S3 0.0v with 0.125 diode to ground is it normal?
Last edited:
12 5.1v
6 1.8v
16 1.8v
17 1.8v
after i measured this now got
PP1V2_S3 1.2v with 0.125 diode to ground
but still bootloop.
Last edited:


Staff member
Did you follow exact steps from DFU tutorial?
im sorry for my stupidity, i press keys wrongly now i tried revive and restore success with no errors
please check on the video revive restore after this now no more display dont know whats the next step
yes but this after the restore no display if u checked the video u can see the screen of other macbook looping the usb connection.
any idea?
this solved after no more option thing to do i decided to spray the entire motherboard with electronic cleaner then
i reheat to make it dry using quick 2008 hotair 240/100
suddenly miracle happens.