820-00165 No Backlight

it-solve

Member
A beer damage board turns on with no backlight. Tried SMC reset, capslock is active and there is USB activity
The backlight blinks for a second once when turns on.

D7701 - 8.6v both sides
XW7720 - 8.6v and clean
BKL_EN - 2.83v
BKL_PWM - 0v
All Return resistors 0.6Vdc

Removed R7704 and tied together BKL_EN and BKL_PWM and backlight stays on.
With the jumper, PPHV_S0SW_LCDBKLT is 24.4V


Does not seems to be U7701, BKL_PWM comes from SMC, reflow?
 
Last edited:

2informaticos

Administrator
Staff member
EDP_BKLT_PWM comes our from PCH.
SMC output is not connected...

Try PRAM reset 2-3 times.
Be sure R7704 and its traces OK.
 

it-solve

Member
With a soldered jumper backlight stays on but when I do a couple of PRAM reset's it goes off. Doesn't it suppose to get forced to stay on?

R7704 to C7704 seems fine, cannot test to Ball 4 on U7701 though. Also cannot test EDP_BKLT_PWM to PCH either (TP1 on EDP_BKLT_PWM seems to be non-existent). Reflowed the U7701 with no effect.
 

Attachments

Last edited:

2informaticos

Administrator
Staff member
Are you sure R7704 is good?
In the picture looks more like a cap; does it have 33 ohm?
You can just replace it with a short.
Also check continuity of its traces; right test point, for example.
 

it-solve

Member
Must have flipped the other way around while resoldering, but yeah measures to 33Ohm between EDP_BKLT+PWM and C7704. Also all traces are connected all the way to the test point.
 
Last edited:

2informaticos

Administrator
Staff member
Do you have backlight forcing PWM now?
If yes, do PRAM reset, rebuild original configuration and test again.
 
Last edited:

it-solve

Member
Soldered jumper forcing PWM, backlight stays on until I do couple PRAM resets. Then I lose it again.
With the original configuration same thing, blinks once initially then no backlight.
 
Top